Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support for non-prefixed PointerLock API #15701

Closed
DartBot opened this issue Dec 18, 2013 · 3 comments

Comments

@DartBot
Copy link

commented Dec 18, 2013

This issue was originally filed by patrick.bo...@gmail.com


What steps will reproduce the problem?

  1. Create a new Web application in Dart Editor
  2. Use PointerLock methods/events, e.g. this main method:

void main() {
  document.onPointerLockChange.listen((e) => print(e));
  querySelector("#sample_container_id").onClick.listen((e) {
    querySelector("#sample_container_id").requestPointerLock();
  });
}

  1. Compile to JS, run in Firefox

What is the expected output? What do you see instead?

I expect PointerLock to work in Firefox, as it is available for some versions, but the generated JS code only tries to call the webkit-prefixed PointerLock API:

document.querySelector("#sample_container_id").webkitRequestPointerLock();

What version of the product are you using? On what operating system?

Dart Editor version 1.0.0_r30798 (STABLE)
Dart SDK version 1.0.0.10_r30798
Mac OS X 10.9

Please provide any additional information below.

@floitschG

This comment has been minimized.

Copy link
Contributor

commented Dec 18, 2013

Added Area-HTML, Triaged labels.

@kevmoo

This comment has been minimized.

Copy link
Member

commented Apr 7, 2014

Removed Area-HTML label.
Added Area-Library, Library-Html labels.

@efortuna

This comment has been minimized.

Copy link
Contributor

commented Aug 8, 2014

Added Duplicate label.
Marked as being merged into #4463.

This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.