New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[VM] make --strong without --dfe an error #31561

Closed
chalin opened this Issue Dec 6, 2017 · 2 comments

Comments

Projects
None yet
4 participants
@chalin
Contributor

chalin commented Dec 6, 2017

Followup to @mraleph's comment in #31534 (comment)

Could you also make --dfe report an error until it is actually implemented?

cc @kwalrath @kevmoo

@a-siva

This comment has been minimized.

Show comment
Hide comment
@a-siva

a-siva Jan 3, 2018

Contributor

@sivachandra is working on cleaning up some of the options that the VM uses when running in 2.0 mode.
The goal is to have a single '--preview-dart-2' option that turns on Dart 2.0 which would be strong mode
by default.
This will be addressed by that change.

Contributor

a-siva commented Jan 3, 2018

@sivachandra is working on cleaning up some of the options that the VM uses when running in 2.0 mode.
The goal is to have a single '--preview-dart-2' option that turns on Dart 2.0 which would be strong mode
by default.
This will be addressed by that change.

@a-siva

This comment has been minimized.

Show comment
Hide comment
@a-siva

a-siva Feb 7, 2018

Contributor

We are making --strong the default for --preview_dart_2 and the --dfe option is not a requirement for running dart with the new front end. This bug is obsolete with the new --preview_dart_2 option.

Contributor

a-siva commented Feb 7, 2018

We are making --strong the default for --preview_dart_2 and the --dfe option is not a requirement for running dart with the new front end. This bug is obsolete with the new --preview_dart_2 option.

@a-siva a-siva closed this Feb 7, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment