Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Annotations #3214

Closed
gbracha opened this issue May 24, 2012 · 2 comments
Closed

Annotations #3214

gbracha opened this issue May 24, 2012 · 2 comments
Assignees
Labels
area-language Deprecated: New language issues should be filed at https://github.com/dart-lang/language type-enhancement
Milestone

Comments

@gbracha
Copy link
Contributor

gbracha commented May 24, 2012

A general purpose annotation/metadata mechanism has many uses. We should have one for Dart.

@gbracha
Copy link
Contributor Author

gbracha commented Jul 11, 2012

Draft proposal and spec made public. Integrated into 0.11 draft.


Removed this from the Later milestone.
Added this to the M1 milestone.
Added Done label.

@gbracha
Copy link
Contributor Author

gbracha commented Jul 11, 2012

Analyzer issue #4056.
VM issue #4057.
dart2js issue #4058.

@gbracha gbracha added Type-Enhancement area-language Deprecated: New language issues should be filed at https://github.com/dart-lang/language labels Jul 11, 2012
@gbracha gbracha self-assigned this Jul 11, 2012
@gbracha gbracha added this to the M1 milestone Jul 11, 2012
copybara-service bot pushed a commit that referenced this issue Oct 17, 2022
…3 revisions)

https://dart.googlesource.com/dartdoc/+log/c8bc0655bbd4..5b3feb67f7db

2022-10-17 49699333+dependabot[bot]@users.noreply.github.com Bump actions/cache from 3.0.10 to 3.0.11 (#3224)
2022-10-17 49699333+dependabot[bot]@users.noreply.github.com Bump actions/checkout from 3.0.2 to 3.1.0 (#3214)
2022-10-17 srawlins@google.com Fix enclosingCombo initialization issue (#3212)

If this roll has caused a breakage, revert this CL and stop the roller
using the controls here:
https://autoroll.skia.org/r/dart-doc-dart-sdk
Please CC dart-ecosystem-gardener@grotations.appspotmail.com on the revert to ensure that a human
is aware of the problem.

To file a bug in Dart Documentation Generator: https://github.com/dart-lang/dartdoc/issues
To file a bug in Dart SDK: https://github.com/dart-lang/sdk/issues

To report a problem with the AutoRoller itself, please file a bug:
https://bugs.chromium.org/p/skia/issues/entry?template=Autoroller+Bug

Documentation for the AutoRoller is here:
https://skia.googlesource.com/buildbot/+doc/main/autoroll/README.md

Tbr: dart-ecosystem-gardener@grotations.appspotmail.com
Change-Id: Ib424a2dfca4c9314faa40fbea3aed8cf891e011a
Reviewed-on: https://dart-review.googlesource.com/c/sdk/+/264581
Commit-Queue: Nate Bosch <nbosch@google.com>
Reviewed-by: Nate Bosch <nbosch@google.com>
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
area-language Deprecated: New language issues should be filed at https://github.com/dart-lang/language type-enhancement
Projects
None yet
Development

No branches or pull requests

3 participants