Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

dart:html IntersectionObserver api requires a call to dart:js allowInterop on dart2js #35484

Closed
jacob314 opened this issue Dec 22, 2018 · 1 comment

Comments

@jacob314
Copy link
Member

commented Dec 22, 2018

I'm guessing we are just missing a call to convert a Dart function into a JS function in the dart:html code generation.

As expected, IntersectionObserver works under DDC where functions can be passed between Dart and JS without conversion.

Example where I had to add allow interop:
flutter/devtools@13c304c

@terrylucas

This comment has been minimized.

Copy link
Member

commented Jan 14, 2019

Fix in CL

@dart-bot dart-bot closed this in edca616 Jan 15, 2019

natebosch added a commit to flutter/devtools that referenced this issue Aug 27, 2019
Remove extraneous calls to allowInterop (#966)
`allowInterop` is intended for use with `package:js` style callback
arguments to `@js()` annotated APIs, it is unnecessary when using APIs
from `dart:html`.

This had been put in to work around dart-lang/sdk#35484
which has since been solved.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.