Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Unclear how to run dart2js with --minify with Editor #8751

Closed
DartBot opened this issue Feb 24, 2013 · 12 comments
Closed

Unclear how to run dart2js with --minify with Editor #8751

DartBot opened this issue Feb 24, 2013 · 12 comments
Assignees
Labels
closed-not-planned Closed as we don't intend to take action on the reported issue type-enhancement A request for a change that isn't a bug
Milestone

Comments

@DartBot
Copy link

DartBot commented Feb 24, 2013

This issue was originally filed by @sethladd


I'm not sure how to run --minify with dart2js when using the Editor.

Right-click, run as JavaScript doesn't have a sub-option.

Going into Manage Run configurations, and nothing jumps out at me. (see screenshot)

Can we make this easier? JavaScript size is one of the most important metrics by which people judge Dart.

Thanks!

@DartBot
Copy link
Author

DartBot commented Feb 24, 2013

This comment was originally written by @sethladd


Attachment:
Screenshot_2_20_13_9_14_PM.png (179.57 KB)

@DartBot
Copy link
Author

DartBot commented Feb 24, 2013

This comment was originally written by @sethladd


Attachment:
[Screen Shot 2013-02-24 at 12.37.37 AM.png](https://storage.googleapis.com/google-code-attachments/dart/issue-8751/comment-2/Screen Shot 2013-02-24 at 12.37.37 AM.png) (126.42 KB)

@DartBot
Copy link
Author

DartBot commented Feb 24, 2013

This comment was originally written by googlegroups...@kaioa.com


Right now it's indeed very well hidden.

  1. right click your project's folder
  2. click on "Properties"
  3. go to "Dart Settings"
  4. write "--minify" in dart2js' "Additional flags" text field

Theoretically, you could also add "--output-type=dart" (dart2dart) there, but then you'd output a minified Dart file with ".js" extension whenever you run "Generate JavaScript".

This really needs some restructuring. Right now I use a batch file to run dart2dart. That's a little bit too low-tech for my taste. I'd prefer to do that from within the editor.

@anders-sandholm
Copy link
Contributor

Removed Type-Defect label.
Added Type-Enhancement, Area-Editor, Triaged labels.

@danrubel
Copy link

Set owner to @devoncarew.
Added this to the M5 milestone.

@sethladd
Copy link
Contributor

Why isn't minify on by default?

@DartBot
Copy link
Author

DartBot commented Mar 16, 2013

This comment was originally written by @sethladd


Answering my own question... minify is more of a deploy step.

@devoncarew
Copy link
Member

Removed this from the M5 milestone.
Added this to the M6 milestone.

@devoncarew
Copy link
Member

Removed this from the M6 milestone.
Added this to the M7 milestone.

@devoncarew
Copy link
Member

Removed this from the M7 milestone.
Added this to the Later milestone.

@devoncarew
Copy link
Member

This will be taken care of by pub build.


Added NotPlanned label.

@clayberg
Copy link

Removed this from the Later milestone.
Added this to the 1.2 milestone.

@DartBot DartBot added Type-Enhancement closed-not-planned Closed as we don't intend to take action on the reported issue labels Feb 11, 2014
@DartBot DartBot added this to the 1.2 milestone Feb 11, 2014
@kevmoo kevmoo added type-enhancement A request for a change that isn't a bug and removed type-enhancement labels Mar 1, 2016
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
closed-not-planned Closed as we don't intend to take action on the reported issue type-enhancement A request for a change that isn't a bug
Projects
None yet
Development

No branches or pull requests

7 participants