Switch branches/tags
Find file History
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
..
Failed to load latest commit information.
bin
lib
test
tool
.gitignore
BUILD.gn
CHANGELOG.md
README.md
analysis_options.yaml
pubspec.yaml

README.md

dartanalyzer

Use dartanalyzer to statically analyze your code at the command line, checking for errors and warnings that are specified in the Dart Language Specification. DartPad, code editors, and IDEs such as WebStorm use the same analysis engine that dartanalyzer uses.

Basic usage

Run the analyzer from the top directory of the package. Here's an example of testing a Dart file.

dartanalyzer bin/test.dart

Options

The following are the most commonly used options for dartanalyzer:

  • --packages=
    Specify the path to the package resolution configuration file. For more information see Package Resolution Configuration File. This option cannot be used with --package-root.

  • --package-warnings
    Show warnings not only for code in the specified .dart file and others in its library, but also for libraries imported with package:.

  • --options=
    Specify the path to an analysis options file.

  • --lints
    Show the results from the linter.

  • --no-hints
    Don't show hints for improving the code.

  • --ignore-unrecognized-flags
    Rather than printing the help message, ignore any unrecognized command-line flags.

  • --version
    Show the analyzer version.

  • -h or --help
    Show all the command-line options.

The following are advanced options to use with dartanalyzer:

  • -b or --batch
    Run in batch mode.

  • --dart-sdk=
    Specify the directory that contains the Dart SDK.

  • --fatal-warnings
    Except for type warnings, treat warnings as fatal.

  • --format=machine
    Produce output in a format suitable for parsing.

  • --url-mapping=libraryUri,/path/to/library.dart
    Tells the analyzer to use the specified library as the source for that particular import.

The following options are deprecated:

  • --package-root=
    Deprecated. Specify the directory to search for any libraries that are imported using package:. This option is replaced as of Dart 1.12 with --packages.