Skip to content
Browse files

added proper gem dependencies (json and fastercsv)

  • Loading branch information...
1 parent 6ce413d commit 76f36792f7f05ecd4e8cdff4fa847bd1bf4be35e @darwin committed Dec 5, 2009
Showing with 8 additions and 3 deletions.
  1. +3 −1 Rakefile
  2. +3 −0 lib/csv2json-version.rb
  3. +2 −2 lib/csv2json.rb
View
4 Rakefile
@@ -1,6 +1,6 @@
require 'rubygems'
require 'rake'
-require File.join(File.expand_path(File.dirname(__FILE__)), 'lib', 'csv2json.rb')
+require File.join(File.expand_path(File.dirname(__FILE__)), 'lib', 'csv2json-version.rb')
begin
require 'jeweler'
@@ -12,6 +12,8 @@ begin
gem.email = "antonin@hildebrand.cz"
gem.homepage = "http://github.com/darwin/csv2json"
gem.authors = ["Antonin Hildebrand"]
+ gem.add_dependency "json"
+ gem.add_dependency "fastercsv"
gem.add_development_dependency "shoulda", ">= 0"
# gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
end
View
3 lib/csv2json-version.rb
@@ -0,0 +1,3 @@
+module CSV2JSON
+ VERSION = "0.1.1"
+end
View
4 lib/csv2json.rb
@@ -1,9 +1,9 @@
require 'fastercsv'
require 'json'
+require 'csv2json-version.rb'
module CSV2JSON
- VERSION = "0.1.0"
-
+
# convert an input string value to integer or float if applicable
def convert(val)
return Integer(val) if val.to_i.to_s == val

0 comments on commit 76f3679

Please sign in to comment.
Something went wrong with that request. Please try again.