Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Snyk] Security upgrade mkdocs from 1.2.3 to 1.3.0 #2034

merged 1 commit into from Apr 3, 2022


Copy link

@snyk-bot snyk-bot commented Apr 1, 2022

Snyk has created this PR to fix one or more vulnerable packages in the `pip` dependencies of this project.

Changes included in this PR

  • Changes to the following files to upgrade the vulnerable dependencies to a fixed version:
    • docs/requirements.txt
⚠️ Warning
pymdown-extensions 8.0 requires Markdown, which is not installed.
mkdocs-material 6.0.1 requires mkdocs-material-extensions, which is not installed.
mkdocs-material 6.0.1 requires markdown, which is not installed.
mkdocs-material 6.0.1 requires mkdocs, which is not installed.

Vulnerabilities that will be fixed

By pinning:
Severity Priority Score (*) Issue Upgrade Breaking Change Exploit Maturity
medium severity 556/1000
Why? Recently disclosed, Has a fix available, CVSS 5.4
Cross-site Scripting (XSS)
1.2.3 -> 1.3.0
No No Known Exploit

(*) Note that the real score may have changed since the PR was raised.

Some vulnerabilities couldn't be fully fixed and so Snyk will still find them when the project is tested again. This may be because the vulnerability existed within more than one direct dependency, but not all of the effected dependencies could be upgraded.

Check the changes in this PR to ensure they won't cause issues with your project.

Note: You are seeing this because you or someone else with access to this repository has authorized Snyk to open fix PRs.

For more information:
🧐 View latest project report

🛠 Adjust project settings

📚 Read more about Snyk's upgrade and patch logic

Learn how to fix vulnerabilities with free interactive lessons:

🦉 Cross-site Scripting (XSS)

The following vulnerabilities are fixed by pinning transitive dependencies:
@snyk-bot snyk-bot requested a review from subotic as a code owner April 1, 2022 21:31
Copy link

sonarcloud bot commented Apr 1, 2022

Kudos, SonarCloud Quality Gate passed!    Quality Gate passed

Bug A 0 Bugs
Vulnerability A 0 Vulnerabilities
Security Hotspot A 0 Security Hotspots
Code Smell A 0 Code Smells

No Coverage information No Coverage information
No Duplication information No Duplication information

@subotic subotic merged commit b07600d into main Apr 3, 2022
@subotic subotic deleted the snyk-fix-c443fc28a3257e2fd82a513e3f5533ec branch April 3, 2022 08:41
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
None yet
None yet

Successfully merging this pull request may close these issues.

None yet

2 participants