Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

First gemspec and build.

  • Loading branch information...
commit 4192bafad3495809788e5b7c4fd2535d42f0de82 1 parent 6d6a763
Aaron Russell aaronrussell authored
4 Rakefile
View
@@ -5,8 +5,8 @@ begin
require 'jeweler'
Jeweler::Tasks.new do |gem|
gem.name = "cloudapp_api"
- gem.summary = %Q{CloudApp API wrapper for Ruby, using HTTParty with an ActiveResource-like interface}
- gem.description = %Q{CloudApp API wrapper for Ruby, using HTTParty with an ActiveResource-like interface}
+ gem.summary = %Q{A simple Ruby wrapper for the CloudApp API. Uses HTTParty with a simple ActiveResource-like interface.}
+ gem.description = %Q{A simple Ruby wrapper for the CloudApp API. Uses HTTParty with a simple ActiveResource-like interface.}
gem.email = "aaron@gc4.co.uk"
gem.homepage = "http://github.com/aaronrussell/cloud_app"
gem.authors = ["Aaron Russell"]
2  VERSION
View
@@ -1 +1 @@
-0.0.0
+0.0.1
61 cloudapp_api.gemspec
View
@@ -0,0 +1,61 @@
+# Generated by jeweler
+# DO NOT EDIT THIS FILE DIRECTLY
+# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
+# -*- encoding: utf-8 -*-
+
+Gem::Specification.new do |s|
+ s.name = %q{cloudapp_api}
+ s.version = "0.0.1"
+
+ s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.authors = ["Aaron Russell"]
+ s.date = %q{2010-05-17}
+ s.description = %q{A simple Ruby wrapper for the CloudApp API. Uses HTTParty with a simple ActiveResource-like interface.}
+ s.email = %q{aaron@gc4.co.uk}
+ s.extra_rdoc_files = [
+ "LICENSE",
+ "README.md"
+ ]
+ s.files = [
+ ".document",
+ ".gitignore",
+ "LICENSE",
+ "README.md",
+ "Rakefile",
+ "VERSION",
+ "lib/cloudapp/base.rb",
+ "lib/cloudapp/client.rb",
+ "lib/cloudapp/httparty.rb",
+ "lib/cloudapp/monkey_patch/httparty.rb",
+ "lib/cloudapp/monkey_patch/net_digest_auth.rb",
+ "lib/cloudapp_api.rb",
+ "test/helper.rb",
+ "test/test_cloudly.rb"
+ ]
+ s.homepage = %q{http://github.com/aaronrussell/cloud_app}
+ s.rdoc_options = ["--charset=UTF-8"]
+ s.require_paths = ["lib"]
+ s.rubygems_version = %q{1.3.6}
+ s.summary = %q{A simple Ruby wrapper for the CloudApp API. Uses HTTParty with a simple ActiveResource-like interface.}
+ s.test_files = [
+ "test/helper.rb",
+ "test/test_cloudly.rb"
+ ]
+
+ if s.respond_to? :specification_version then
+ current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
+ s.specification_version = 3
+
+ if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
+ s.add_runtime_dependency(%q<httparty>, [">= 0.5.2"])
+ s.add_development_dependency(%q<thoughtbot-shoulda>, [">= 0"])
+ else
+ s.add_dependency(%q<httparty>, [">= 0.5.2"])
+ s.add_dependency(%q<thoughtbot-shoulda>, [">= 0"])
+ end
+ else
+ s.add_dependency(%q<httparty>, [">= 0.5.2"])
+ s.add_dependency(%q<thoughtbot-shoulda>, [">= 0"])
+ end
+end
+
1  lib/cloudapp/base.rb
View
@@ -44,7 +44,6 @@ def self.create(kind, opts = {})
attr_accessor :attributes
def initialize(attributes = {})
- @attributes
load(attributes)
end
Please sign in to comment.
Something went wrong with that request. Please try again.