New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

File->Import Database->Graph Database... menu item not available after installation #1

Open
jakob-beetz opened this Issue Nov 18, 2012 · 4 comments

Comments

Projects
None yet
5 participants
@jakob-beetz
Copy link

jakob-beetz commented Nov 18, 2012

After installing the gephi-bluprints-plugins (both nbm's) exactly as described in the wiki, no menu option File->import Database->Graph Database is showing up.

Gephi-version 0.8.1 beta

Any help is very much appreciated

@TimmyStorms

This comment has been minimized.

Copy link
Collaborator

TimmyStorms commented Nov 19, 2012

Hi Jakob,

I've updated the downloadable files. Can you please try these ones?

The problem was that the org.gephi.blueprints.plugin wasn't eagerly loaded, thus org-gephi-blueprints-plugin.xml has been changed from

<module name="org.gephi.blueprints.plugin">
    <param name="autoload">true</param>
    <param name="eager">false</param>
    <param name="jar">modules/org-gephi-blueprints-plugin.jar</param>
    <param name="reloadable">false</param>
</module>

to

<module name="org.gephi.blueprints.plugin">
    <param name="autoload">false</param>
    <param name="eager">true</param>
    <param name="jar">modules/org-gephi-blueprints-plugin.jar</param>
    <param name="reloadable">false</param>
</module>

Although the plugin is specified as "module type:eager" in my development environment, it isn't exported as one. Maybe this is due to a bug in Netbeans, or due to my limited knowlegde of the Netbeans framework. ;-)

Hope this helps!

Timmy

ps: don't forget to add a configuration file in etc/graph to be able to use this plugin!

@ghost ghost assigned TimmyStorms Nov 19, 2012

@sgomezvillamor

This comment has been minimized.

Copy link

sgomezvillamor commented Nov 28, 2012

Although I've just downloaded the plugins, I have the same problem.

Also, I get this exception when I click "Import database --> Graph database"

java.lang.NoClassDefFoundError: Could not initialize class org.gephi.blueprints.plugin.config.GraphConfigurationReader
    at org.gephi.blueprints.plugin.ui.GraphDbImporterUI.getPanel(GraphDbImporterUI.java:29)
    at org.gephi.desktop.importer.DesktopImportControllerUI.importDatabase(DesktopImportControllerUI.java:332)
    at org.gephi.desktop.importer.DesktopImportControllerUI.importDatabase(DesktopImportControllerUI.java:318)
    at org.gephi.desktop.importer.ImportDB$1.actionPerformed(ImportDB.java:92)
    at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2028)

Just to provide as much information as possible:

  • I'm using Gephi 0.8.1 for Mac OS X
  • I've added the xml configuration files here /Users/sgomez/Desktop/gephi.app/Contents/Resources/gephi/etc, but even if there is no configuration file there, I get the exception
@ntroutman

This comment has been minimized.

Copy link

ntroutman commented Mar 22, 2013

I'm also on a Mac and had to add it into /etc/graph which is annoying since it requires root permissions to make a directory their. I would have expected to be able to use ~/Library/Application\ Support/gephi/0.8.2/etc/graph/.

@lukosan

This comment has been minimized.

Copy link

lukosan commented Aug 7, 2017

I'm running gephi on OSX 10.11.16 El Capitan. When I install the plugin I get the "Imports database --> Graph database..." menu item but when I click on it nothing happens.

I notice from the src code that it's looking for the configs in:

System.getProperty("user.dir") + "/etc/graph/"

and rumour has it that this sys property isn't particularly reliable on a Mac. I've tried putting the config files in various locations (including /etc/graph and gephi's etc folder which is at /Applications/Gephi.app/Contents/Resources/gephi/etc and even ~/etc/graph) but no change. My struggles are exarcerbated by the fact that I can't for the life of me find where the programme is logging to - does anyone know where the logs are on OSX?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment