Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
tree: 843ed2cf62
Fetching contributors…

Cannot retrieve contributors at this time

62 lines (45 sloc) 2.357 kB
layout title body_id created_at
default
Installation Issues
docs
Tue Dec 04 13:20:00 +1030 2007

{{ page.title }}

If you've followed the install instructions but run into problems, you can find some tips below.

Dependencies

First port of call if you're having issues with an installation is to make sure you have all the dependencies installed. RubyGems should take care of this for you, but just in case, make sure you have the following gems as well:

Installing an adapter

You will also need to install the adapter for your platform:

{% highlight bash linenos %} gem install dm-mysql-adapter {% endhighlight %}

The current database adapters are:

There are also many more database, and non-database, adapters. Have a look at the (probably incomplete) list on the github wiki. Additionally, a quick github search might reveal some more.

Uninstalling all DataMapper gems

Should you ever have the need to uninstall datamapper completely, Dan Kubb has prepared a bash command that does the trick. Have a look at this gist for a oneliner that gets rid of datamapper completely.

Getting Help

If you still have issues, we suggest getting onto the mailing list or the IRC channel and asking around. There are friendly people there to help you out.

Jump to Line
Something went wrong with that request. Please try again.