Skip to content
This repository
Browse code

Change gem dependencies to latest

* This is a test to see if dm-rails can build with the resulting Gemfile
  • Loading branch information...
commit 04569503ff62b69825929131ae69854714f6b8c2 1 parent 3ba4a9e
Dan Kubb dkubb authored

Showing 2 changed files with 24 additions and 26 deletions. Show diff stats Hide diff stats

  1. +1 1  templates/rails/config.rb
  2. +23 25 templates/rails/gemfile.rb
2  templates/rails/config.rb
@@ -10,4 +10,4 @@
10 10 require 'active_resource/railtie'
11 11 require 'rails/test_unit/railtie'
12 12 RUBY
13   -end
  13 +end
48 templates/rails/gemfile.rb
@@ -15,12 +15,12 @@
15 15 RAILS_VERSION = '~> #{Rails::VERSION::STRING}'
16 16 DM_VERSION = '~> 1.2.0'
17 17
18   -gem 'activesupport', RAILS_VERSION, :require => 'active_support'
19   -gem 'actionpack', RAILS_VERSION, :require => 'action_pack'
20   -gem 'actionmailer', RAILS_VERSION, :require => 'action_mailer'
21   -gem 'activeresource', RAILS_VERSION, :require => 'active_resource'
22   -gem 'railties', RAILS_VERSION, :require => 'rails'
23   -gem 'tzinfo'
  18 +gem 'activesupport', RAILS_VERSION, :require => 'active_support'
  19 +gem 'actionpack', RAILS_VERSION, :require => 'action_pack'
  20 +gem 'actionmailer', RAILS_VERSION, :require => 'action_mailer'
  21 +gem 'activeresource', RAILS_VERSION, :require => 'active_resource'
  22 +gem 'railties', RAILS_VERSION, :require => 'rails'
  23 +gem 'tzinfo', '~> 0.3.32'
24 24
25 25 gem 'dm-rails', '~> 1.2.1'
26 26 gem 'dm-#{database}-adapter', DM_VERSION
@@ -40,42 +40,40 @@
40 40 # gem 'dm-oracle-adapter', DM_VERSION
41 41 # gem 'dm-sqlserver-adapter', DM_VERSION
42 42
43   -gem 'dm-migrations', DM_VERSION
44   -gem 'dm-types', DM_VERSION
45   -gem 'dm-validations', DM_VERSION
46   -gem 'dm-constraints', DM_VERSION
47   -gem 'dm-transactions', DM_VERSION
48   -gem 'dm-aggregates', DM_VERSION
49   -gem 'dm-timestamps', DM_VERSION
50   -gem 'dm-observer', DM_VERSION
51   -
  43 +gem 'dm-migrations', DM_VERSION
  44 +gem 'dm-types', DM_VERSION
  45 +gem 'dm-validations', DM_VERSION
  46 +gem 'dm-constraints', DM_VERSION
  47 +gem 'dm-transactions', DM_VERSION
  48 +gem 'dm-aggregates', DM_VERSION
  49 +gem 'dm-timestamps', DM_VERSION
  50 +gem 'dm-observer', DM_VERSION
52 51
53 52 # Gems used only for assets and not required
54 53 # in production environments by default.
55 54 group :assets do
56   - gem 'sass-rails', '~> 3.1.5'
57   - gem 'coffee-rails', '~> 3.1.1'
58   - gem 'uglifier', '>= 1.0.3'
  55 + gem 'sass-rails', '~> 3.2.5'
  56 + gem 'coffee-rails', '~> 3.2.2'
  57 + gem 'uglifier', '~> 1.2.4'
59 58 end
60 59
61   -gem 'jquery-rails'
  60 +gem 'jquery-rails', '~> 2.0.1'
62 61
63 62 # To use ActiveModel has_secure_password
64   -# gem 'bcrypt-ruby', '~> 3.0.0'
  63 +# gem 'bcrypt-ruby', '~> 3.0.1'
65 64
66 65 # Use unicorn as the web server
67   -# gem 'unicorn'
  66 +# gem 'unicorn', '~> 4.2.1'
68 67
69 68 # Deploy with Capistrano
70   -# gem 'capistrano'
  69 +# gem 'capistrano', '~> 2.11.2'
71 70
72 71 # To use debugger
73   -# gem 'ruby-debug19', :require => 'ruby-debug'
  72 +# gem 'ruby-debug19', '~> 0.11.6', :require => 'ruby-debug'
74 73
75 74 group :test do
76 75 # Pretty printed test output
77   - gem 'turn', '~> 0.8.3', :require => false
  76 + gem 'turn', '~> 0.9.4', :require => false
78 77 end
79   -
80 78 GEMFILE
81 79 end

0 comments on commit 0456950

Please sign in to comment.
Something went wrong with that request. Please try again.