Skip to content
Browse files

Bump virtus dependency to ~> 0.5

This makes it possible to have dm-core coexist
with veritas and friends.

virtus 0.5 hasn't yet been released so virtus is
pinned to github in the Gemfile for now.
  • Loading branch information...
1 parent 9d9f739 commit 5c9de2aa28339cb0d9798420727cf39d0e572e51 @snusnu snusnu committed Jun 4, 2012
Showing with 3 additions and 1 deletion.
  1. +2 −0 Gemfile
  2. +1 −1 dm-core.gemspec
View
2 Gemfile
@@ -6,6 +6,8 @@ source :rubygems
gemspec
+gem 'virtus', '~> 0.5', :github => 'solnic/virtus'
@postmodern
DataMapper member
postmodern added a note Jun 5, 2012

Need to make that a proper URI for Bundler 1.0.x.

@snusnu
DataMapper member
snusnu added a note Jun 5, 2012

@postmodern Thx for reminding me! done in 5c9de2a...230a1d3

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
+
SOURCE = ENV.fetch('SOURCE', :git).to_sym
REPO_POSTFIX = SOURCE == :path ? '' : '.git'
DATAMAPPER = SOURCE == :path ? Pathname(__FILE__).dirname.parent : 'http://github.com/datamapper'
View
2 dm-core.gemspec
@@ -18,7 +18,7 @@ Gem::Specification.new do |gem|
gem.version = DataMapper::VERSION
gem.add_runtime_dependency('addressable', '~> 2.2.6')
- gem.add_runtime_dependency('virtus', '~> 0.4.1')
+ gem.add_runtime_dependency('virtus', '~> 0.5')
gem.add_development_dependency('rake', '~> 0.9.2')
gem.add_development_dependency('rspec', '~> 1.3.2')

0 comments on commit 5c9de2a

Please sign in to comment.
Something went wrong with that request. Please try again.