Skip to content
Browse files

Remove jeweler

  • Loading branch information...
1 parent 3215e75 commit 6c9f2740a8a2909b2afa0322ee4a352387c40866 @solnic solnic committed Nov 7, 2011
Showing with 29 additions and 79 deletions.
  1. +3 −2 Gemfile
  2. +1 −21 Rakefile
  3. +18 −56 dm-do-adapter.gemspec
  4. +7 −0 lib/dm-do-adapter/version.rb
View
5 Gemfile
@@ -1,6 +1,8 @@
require 'pathname'
-source 'http://rubygems.org'
+source :rubygems
+
+gemspec
SOURCE = ENV.fetch('SOURCE', :git).to_sym
REPO_POSTFIX = SOURCE == :path ? '' : '.git'
@@ -19,7 +21,6 @@ gem 'dm-core', DM_VERSION,
group :development do
- gem 'jeweler', '~> 1.6.4'
gem 'rake', '~> 0.9.2'
gem 'rspec', '~> 1.3.2'
View
22 Rakefile
@@ -1,26 +1,6 @@
require 'rubygems'
require 'rake'
-begin
- gem 'jeweler', '~> 1.6.4'
- require 'jeweler'
-
- Jeweler::Tasks.new do |gem|
- gem.name = 'dm-do-adapter'
- gem.summary = 'DataObjects Adapter for DataMapper'
- gem.description = gem.summary
- gem.email = 'dan.kubb@gmail.com'
- gem.homepage = 'http://github.com/datamapper/%s' % gem.name
- gem.authors = [ 'Dan Kubb' ]
-
- gem.rubyforge_project = 'datamapper'
- end
-
- Jeweler::GemcutterTasks.new
-
- FileList['tasks/**/*.rake'].each { |task| import task }
-rescue LoadError
- puts 'Jeweler (or a dependency) not available. Install it with: gem install jeweler'
-end
+FileList['tasks/**/*.rake'].each { |task| import task }
task(:spec) {} # this adapter only provides shared specs that are exercised by real adapters
View
74 dm-do-adapter.gemspec
@@ -1,62 +1,24 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
+require File.expand_path('../lib/dm-do-adapter/version', __FILE__)
-Gem::Specification.new do |s|
- s.name = "dm-do-adapter"
- s.version = "1.3.0.beta"
+Gem::Specification.new do |gem|
+ gem.authors = [ "Dan Kubb" ]
+ gem.email = [ "dan.kubb@gmail.com" ]
+ gem.summary = "DataObjects Adapter for DataMapper"
+ gem.description = gem.summary
+ gem.homepage = "http://datamapper.org"
- s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
- s.authors = ["Dan Kubb"]
- s.date = "2011-10-15"
- s.description = "DataObjects Adapter for DataMapper"
- s.email = "dan.kubb@gmail.com"
- s.extra_rdoc_files = [
- "LICENSE",
- "README.rdoc"
- ]
- s.files = [
- "Gemfile",
- "LICENSE",
- "README.rdoc",
- "Rakefile",
- "VERSION",
- "dm-do-adapter.gemspec",
- "lib/dm-do-adapter.rb",
- "lib/dm-do-adapter/adapter.rb",
- "lib/dm-do-adapter/spec/shared_spec.rb",
- "tasks/yard.rake",
- "tasks/yardstick.rake"
- ]
- s.homepage = "http://github.com/datamapper/dm-do-adapter"
- s.require_paths = ["lib"]
- s.rubyforge_project = "datamapper"
- s.rubygems_version = "1.8.11"
- s.summary = "DataObjects Adapter for DataMapper"
+ gem.files = `git ls-files`.split("\n")
+ gem.test_files = `git ls-files -- {spec}/*`.split("\n")
+ gem.extra_rdoc_files = %w[LICENSE README.rdoc]
- if s.respond_to? :specification_version then
- s.specification_version = 3
+ gem.name = "dm-do-adapter"
+ gem.require_paths = [ "lib" ]
+ gem.version = DataMapper::Adapters::DataObjectsAdapter::VERSION
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<data_objects>, ["~> 0.10.6"])
- s.add_runtime_dependency(%q<dm-core>, ["~> 1.3.0.beta"])
- s.add_development_dependency(%q<jeweler>, ["~> 1.6.4"])
- s.add_development_dependency(%q<rake>, ["~> 0.9.2"])
- s.add_development_dependency(%q<rspec>, ["~> 1.3.2"])
- else
- s.add_dependency(%q<data_objects>, ["~> 0.10.6"])
- s.add_dependency(%q<dm-core>, ["~> 1.3.0.beta"])
- s.add_dependency(%q<jeweler>, ["~> 1.6.4"])
- s.add_dependency(%q<rake>, ["~> 0.9.2"])
- s.add_dependency(%q<rspec>, ["~> 1.3.2"])
- end
- else
- s.add_dependency(%q<data_objects>, ["~> 0.10.6"])
- s.add_dependency(%q<dm-core>, ["~> 1.3.0.beta"])
- s.add_dependency(%q<jeweler>, ["~> 1.6.4"])
- s.add_dependency(%q<rake>, ["~> 0.9.2"])
- s.add_dependency(%q<rspec>, ["~> 1.3.2"])
- end
-end
+ gem.add_runtime_dependency(%q<data_objects>, ["~> 0.10.6"])
+ gem.add_runtime_dependency(%q<dm-core>, ["~> 1.3.0.beta"])
+ gem.add_development_dependency(%q<rake>, ["~> 0.9.2"])
+ gem.add_development_dependency(%q<rspec>, ["~> 1.3.2"])
+end
View
7 lib/dm-do-adapter/version.rb
@@ -0,0 +1,7 @@
+module DataMapper
+ module Adapters
+ module DataObjectsAdapter
+ VERSION = '1.3.0.beta'
+ end
+ end
+end

0 comments on commit 6c9f274

Please sign in to comment.
Something went wrong with that request. Please try again.