Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

DataObjects::URI.new with arguments is deprecated warning #4

Closed
emonti opened this Issue · 21 comments
@emonti

As of data_objects 0.10.5 I have begun getting the following warning in my datamapper project

DataObjects::URI.new with arguments is deprecated, use a Hash of URI components (.../gems/dm-do-adapter-1.1.0/lib/dm-do-adapter/adapter.rb:231:in `new')

@emonti

sorry, i just checked. looks like you've already fixed this in 1.1.1 - push that gem! :)

@emonti emonti closed this
@solnic
Owner

@emonti yeah man we'll be releasing within the next few days...we just need to find some time to write release notes :)

@DAddYE

@solnic the released gem don't contain this fix... why?

@solnic
Owner

@DAddYE we're waiting with releasing dm 1.1.1 because we found a nasty bug in latest DO. Unfortunately we already bumped DO dependency to 0.10.5 that's why it's a blocker :(

@dgmdan

Ran into this issue as well when using the current released gem (1.1.0). Glad to know an update is on the way.

@bgreenlee

Any update on when the 1.1.1 gem will be pushed?

@solnic
Owner

@bgreenlee Next week and probably it's gonna be 1.2.0

@chenillen

didn't find the 1.1.1 gem update....

@orlybg

any workaround while the new gem is pushed?

@jasonmadigan

Glad to hear a fix is coming.

@delonnewman

Glad to hear a fix is coming too, but I'd like to second @orlybg.

@solnic
Owner

@delonnewman yeah just apply this patch 7f0b53d

@AdrienGiboire

Noob question: How apply this patch ? I use DataMapper in a Sinatra app. I will not patch the gem itself. So?

@solnic
Owner

@whoshallsucceed just use latest RC2 of DataMapper, it's fixed there gem install datamapper --pre

@AdrienGiboire

Oh thanks!

@jinzishuai

somehow I am unable to install data_mapper, even though the dm-core-1.2.0.rc2 was just installed:

# gem install dm-core dm-aggregates data_mapper --pre
Successfully installed dm-core-1.2.0.rc2
Successfully installed dm-aggregates-1.2.0.rc2
ERROR:  Error installing data_mapper:
    data_mapper requires dm-aggregates (= 1.2.0.rc2, runtime)
2 gems installed
Installing ri documentation for dm-core-1.2.0.rc2...
Installing ri documentation for dm-aggregates-1.2.0.rc2...
Installing RDoc documentation for dm-core-1.2.0.rc2...
Installing RDoc documentation for dm-aggregates-1.2.0.rc2...
@solnic
Owner

@jinzishuai weird, works for me:

gem install dm-core dm-aggregates data_mapper --pre

Fetching: dm-core-1.2.0.rc2.gem (100%)
Successfully installed dm-core-1.2.0.rc2
Fetching: dm-aggregates-1.2.0.rc2.gem (100%)
Successfully installed dm-aggregates-1.2.0.rc2
Fetching: dm-constraints-1.2.0.rc2.gem (100%)
Fetching: dm-migrations-1.2.0.rc2.gem (100%)
Fetching: dm-transactions-1.2.0.rc2.gem (100%)
Fetching: dm-serializer-1.2.0.rc2.gem (100%)
Fetching: dm-timestamps-1.2.0.rc2.gem (100%)
Fetching: dm-validations-1.2.0.rc2.gem (100%)
Fetching: bcrypt-ruby-3.0.1.gem (100%)
Building native extensions.  This could take a while...
Fetching: stringex-1.3.0.gem (100%)
Fetching: dm-types-1.2.0.rc2.gem (100%)
Fetching: data_mapper-1.2.0.rc2.gem (100%)
Successfully installed dm-constraints-1.2.0.rc2
Successfully installed dm-migrations-1.2.0.rc2
Successfully installed dm-transactions-1.2.0.rc2
Successfully installed dm-serializer-1.2.0.rc2
Successfully installed dm-timestamps-1.2.0.rc2
Successfully installed dm-validations-1.2.0.rc2
Successfully installed bcrypt-ruby-3.0.1
Successfully installed stringex-1.3.0
Successfully installed dm-types-1.2.0.rc2
Successfully installed data_mapper-1.2.0.rc2
12 gems installed
@jinzishuai
@solnic
Owner

@jinzishuai osx lion but this shouldn't matter

@richmeyers

This caused integrity/integrity@9b990ab and subsequently integrity/integrity#143 (comment). Why could you not have left the old API alone?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.