Permalink
Browse files

Bump version to 1.3.0.beta

  • Loading branch information...
1 parent 0c7cf64 commit 06a878596d7b5844e4b58f082b0a259733750e50 @solnic solnic committed Oct 15, 2011
Showing with 11 additions and 11 deletions.
  1. +1 −1 Gemfile
  2. +1 −1 VERSION
  3. +6 −6 dm-migrations.gemspec
  4. +3 −3 lib/dm-migrations/adapters/dm-do-adapter.rb
View
@@ -5,7 +5,7 @@ source 'http://rubygems.org'
SOURCE = ENV.fetch('SOURCE', :git).to_sym
REPO_POSTFIX = SOURCE == :path ? '' : '.git'
DATAMAPPER = SOURCE == :path ? Pathname(__FILE__).dirname.parent : 'http://github.com/datamapper'
-DM_VERSION = '~> 1.2.0'
+DM_VERSION = '~> 1.3.0.beta'
DO_VERSION = '~> 0.10.6'
DM_DO_ADAPTERS = %w[ sqlite postgres mysql oracle sqlserver ]
CURRENT_BRANCH = ENV.fetch('GIT_BRANCH', 'master')
View
@@ -1 +1 @@
-1.2.0
+1.3.0.beta
View
@@ -5,11 +5,11 @@
Gem::Specification.new do |s|
s.name = "dm-migrations"
- s.version = "1.2.0"
+ s.version = "1.3.0.beta"
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = ["Paul Sadauskas"]
- s.date = "2011-10-09"
+ s.date = "2011-10-15"
s.description = "DataMapper plugin for writing and speccing migrations"
s.email = "psadauskas [a] gmail [d] com"
s.extra_rdoc_files = [
@@ -84,18 +84,18 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<dm-core>, ["~> 1.2.0"])
+ s.add_runtime_dependency(%q<dm-core>, ["~> 1.3.0.beta"])
s.add_development_dependency(%q<jeweler>, ["~> 1.6.4"])
s.add_development_dependency(%q<rake>, ["~> 0.9.2"])
s.add_development_dependency(%q<rspec>, ["~> 1.3.2"])
else
- s.add_dependency(%q<dm-core>, ["~> 1.2.0"])
+ s.add_dependency(%q<dm-core>, ["~> 1.3.0.beta"])
s.add_dependency(%q<jeweler>, ["~> 1.6.4"])
s.add_dependency(%q<rake>, ["~> 0.9.2"])
s.add_dependency(%q<rspec>, ["~> 1.3.2"])
end
else
- s.add_dependency(%q<dm-core>, ["~> 1.2.0"])
+ s.add_dependency(%q<dm-core>, ["~> 1.3.0.beta"])
s.add_dependency(%q<jeweler>, ["~> 1.6.4"])
s.add_dependency(%q<rake>, ["~> 0.9.2"])
s.add_dependency(%q<rspec>, ["~> 1.3.2"])
@@ -195,10 +195,10 @@ def create_unique_index_statements(model)
# @api private
def property_schema_hash(property)
- primitive = property.primitive
- type_map = self.class.type_map
+ dump_class = property.dump_class
+ type_map = self.class.type_map
- schema = (type_map[property.class] || type_map[primitive]).merge(:name => property.field)
+ schema = (type_map[property.class] || type_map[dump_class]).merge(:name => property.field)
schema_primitive = schema[:primitive]

0 comments on commit 06a8785

Please sign in to comment.