Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Version bump to 1.0.0.rc1

  • Loading branch information...
commit 20ede6accd579e688920b5681e3f9c73c87b7140 1 parent 0a74902
@dkubb dkubb authored
Showing with 10 additions and 17 deletions.
  1. +2 −6 Gemfile
  2. +1 −1  Rakefile
  3. +1 −1  VERSION
  4. +6 −9 dm-migrations.gemspec
View
8 Gemfile
@@ -71,7 +71,7 @@
source 'http://rubygems.org'
DATAMAPPER = 'git://github.com/datamapper'
-
+DM_VERSION = '~> 1.0.0.rc1'
group :runtime do # Runtime dependencies (as in the gemspec)
@@ -81,8 +81,7 @@ group :runtime do # Runtime dependencies (as in the gemspec)
gem 'activesupport', '~> 3.0.0.beta3', :git => 'git://github.com/rails/rails.git', :require => nil
end
- gem 'dm-core', '~> 0.10.3', :git => "#{DATAMAPPER}/dm-core.git"
-
+ gem 'dm-core', DM_VERSION, :git => "#{DATAMAPPER}/dm-core.git"
end
@@ -103,13 +102,10 @@ group :quality do # These gems contain rake tasks that check the quality of the
gem 'yard', '~> 0.5'
gem 'yardstick', '~> 0.1'
-
end
group :datamapper do # We need this because we want to pin these dependencies to their git master sources
- DM_VERSION = '~> 0.10.3'
-
adapters = ENV['ADAPTER'] || ENV['ADAPTERS']
adapters = adapters.to_s.gsub(',',' ').split(' ') - ['in_memory']
View
2  Rakefile
@@ -15,7 +15,7 @@ begin
gem.rubyforge_project = 'datamapper'
- gem.add_dependency 'dm-core', '~> 0.10.3'
+ gem.add_dependency 'dm-core', '~> 1.0.0.rc1'
gem.add_development_dependency 'rspec', '~> 1.3'
end
View
2  VERSION
@@ -1 +1 @@
-0.10.3
+1.0.0.rc1
View
15 dm-migrations.gemspec
@@ -5,11 +5,11 @@
Gem::Specification.new do |s|
s.name = %q{dm-migrations}
- s.version = "0.10.3"
+ s.version = "1.0.0.rc1"
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = ["Paul Sadauskas"]
- s.date = %q{2010-05-10}
+ s.date = %q{2010-05-19}
s.description = %q{DataMapper plugin for writing and speccing migrations}
s.email = %q{psadauskas [a] gmail [d] com}
s.extra_rdoc_files = [
@@ -107,18 +107,15 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<dm-core>, ["~> 0.10.3"])
+ s.add_runtime_dependency(%q<dm-core>, ["~> 1.0.0.rc1"])
s.add_development_dependency(%q<rspec>, ["~> 1.3"])
- s.add_development_dependency(%q<yard>, ["~> 0.5"])
else
- s.add_dependency(%q<dm-core>, ["~> 0.10.3"])
+ s.add_dependency(%q<dm-core>, ["~> 1.0.0.rc1"])
s.add_dependency(%q<rspec>, ["~> 1.3"])
- s.add_dependency(%q<yard>, ["~> 0.5"])
end
else
- s.add_dependency(%q<dm-core>, ["~> 0.10.3"])
+ s.add_dependency(%q<dm-core>, ["~> 1.0.0.rc1"])
s.add_dependency(%q<rspec>, ["~> 1.3"])
- s.add_dependency(%q<yard>, ["~> 0.5"])
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.