Permalink
Browse files

[dm-more] Remove rubygems usage from libraries

* No longer require dm-core inside the plugins.  Expected usage is to
  require dm-core prior to requiring the plugin.
* Updated pathname creation to using Pathname#/ where possible
  • Loading branch information...
1 parent a900bb8 commit 771372c025cb4307115c038e615564b9381509f1 @dkubb dkubb committed Jun 12, 2009
Showing with 5 additions and 8 deletions.
  1. +5 −8 spec/spec_helper.rb
View
@@ -4,15 +4,12 @@
gem 'dm-core', '0.10.0'
require 'dm-core'
-gem 'rspec', '>1.1.12'
-require 'spec'
+ROOT = Pathname(__FILE__).dirname.parent
-ROOT = Pathname(__FILE__).dirname.expand_path.parent
-
-require ROOT + 'lib/dm-migrations'
-require ROOT + 'lib/migration'
-require ROOT + 'lib/migration_runner'
-require ROOT + 'lib/sql'
+require ROOT / 'lib' / 'dm-migrations'
+require ROOT / 'lib' / 'migration'
+require ROOT / 'lib' / 'migration_runner'
+require ROOT / 'lib' / 'sql'
ADAPTERS = []
def load_driver(name, default_uri)

0 comments on commit 771372c

Please sign in to comment.