Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse code

Updated jeweler dep to 1.5.2

* Updated activesupport dep to 3.0.4
  • Loading branch information...
commit 50899bcffeae5815f006e610dfc2b64b23a31b99 1 parent 4b9c8ee
Dan Kubb authored
4  Gemfile
@@ -24,7 +24,7 @@ group(:development) do # Development dependencies (as in the gemspec)
24 24
 
25 25
   gem 'rake',            '~> 0.8.7'
26 26
   gem 'rspec',           '~> 1.3.1'
27  
-  gem 'jeweler',         '~> 1.4.0'
  27
+  gem 'jeweler',         '~> 1.5.2'
28 28
 
29 29
 end
30 30
 
@@ -33,7 +33,7 @@ group :datamapper do # We need this because we want to pin these dependencies to
33 33
   if ENV['EXTLIB']
34 34
     gem 'extlib',        '~> 0.9.15', SOURCE => "#{DATAMAPPER}/extlib#{REPO_POSTFIX}", :require => nil
35 35
   else
36  
-    gem 'activesupport', '~> 3.0.3', :require => nil
  36
+    gem 'activesupport', '~> 3.0.4', :require => nil
37 37
   end
38 38
 
39 39
   gem 'dm-core',         DM_VERSION, SOURCE => "#{DATAMAPPER}/dm-core#{REPO_POSTFIX}"
9  Rakefile
@@ -2,7 +2,7 @@ require 'rubygems'
2 2
 require 'rake'
3 3
 
4 4
 begin
5  
-  gem 'jeweler', '~> 1.4'
  5
+  gem 'jeweler', '~> 1.5.2'
6 6
   require 'jeweler'
7 7
 
8 8
   Jeweler::Tasks.new do |gem|
@@ -15,16 +15,11 @@ begin
15 15
     gem.has_rdoc    = 'yard'
16 16
 
17 17
     gem.rubyforge_project = 'datamapper'
18  
-
19  
-    gem.add_dependency 'do_postgres',   '~> 0.10.2'
20  
-    gem.add_dependency 'dm-do-adapter', '~> 1.0.2'
21  
-
22  
-    gem.add_development_dependency 'rspec', '~> 1.3'
23 18
   end
24 19
 
25 20
   Jeweler::GemcutterTasks.new
26 21
 
27 22
   FileList['tasks/**/*.rake'].each { |task| import task }
28 23
 rescue LoadError
29  
-  puts 'Jeweler (or a dependency) not available. Install it with: gem install jeweler'
  24
+  puts 'Jeweler (or a dependency) not available. Install it with: gem install jeweler -v 1.5.2'
30 25
 end
57  dm-postgres-adapter.gemspec
... ...
@@ -1,6 +1,6 @@
1 1
 # Generated by jeweler
2 2
 # DO NOT EDIT THIS FILE DIRECTLY
3  
-# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
  3
+# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
4 4
 # -*- encoding: utf-8 -*-
5 5
 
6 6
 Gem::Specification.new do |s|
@@ -9,59 +9,64 @@ Gem::Specification.new do |s|
9 9
 
10 10
   s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
11 11
   s.authors = ["Dan Kubb"]
12  
-  s.date = %q{2010-11-26}
  12
+  s.date = %q{2011-02-18}
13 13
   s.description = %q{PostgreSQL Adapter for DataMapper}
14 14
   s.email = %q{dan.kubb@gmail.com}
15 15
   s.extra_rdoc_files = [
16 16
     "LICENSE"
17 17
   ]
18 18
   s.files = [
19  
-    ".gitignore",
20  
-     "Gemfile",
21  
-     "LICENSE",
22  
-     "Rakefile",
23  
-     "VERSION",
24  
-     "dm-postgres-adapter.gemspec",
25  
-     "lib/dm-postgres-adapter.rb",
26  
-     "lib/dm-postgres-adapter/adapter.rb",
27  
-     "lib/dm-postgres-adapter/spec/setup.rb",
28  
-     "spec/adapter_spec.rb",
29  
-     "spec/rcov.opts",
30  
-     "spec/spec.opts",
31  
-     "spec/spec_helper.rb",
32  
-     "tasks/spec.rake",
33  
-     "tasks/yard.rake",
34  
-     "tasks/yardstick.rake"
  19
+    "Gemfile",
  20
+    "LICENSE",
  21
+    "Rakefile",
  22
+    "VERSION",
  23
+    "dm-postgres-adapter.gemspec",
  24
+    "lib/dm-postgres-adapter.rb",
  25
+    "lib/dm-postgres-adapter/adapter.rb",
  26
+    "lib/dm-postgres-adapter/spec/setup.rb",
  27
+    "spec/adapter_spec.rb",
  28
+    "spec/rcov.opts",
  29
+    "spec/spec.opts",
  30
+    "spec/spec_helper.rb",
  31
+    "tasks/spec.rake",
  32
+    "tasks/yard.rake",
  33
+    "tasks/yardstick.rake"
35 34
   ]
36  
-  s.has_rdoc = %q{yard}
37 35
   s.homepage = %q{http://github.com/datamapper/dm-postgres-adapter}
38  
-  s.rdoc_options = ["--charset=UTF-8"]
39 36
   s.require_paths = ["lib"]
40 37
   s.rubyforge_project = %q{datamapper}
41  
-  s.rubygems_version = %q{1.3.7}
  38
+  s.rubygems_version = %q{1.5.2}
42 39
   s.summary = %q{PostgreSQL Adapter for DataMapper}
43 40
   s.test_files = [
44 41
     "spec/adapter_spec.rb",
45  
-     "spec/spec_helper.rb"
  42
+    "spec/spec_helper.rb"
46 43
   ]
47 44
 
48 45
   if s.respond_to? :specification_version then
49  
-    current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
50 46
     s.specification_version = 3
51 47
 
52 48
     if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
53 49
       s.add_runtime_dependency(%q<do_postgres>, ["~> 0.10.2"])
54 50
       s.add_runtime_dependency(%q<dm-do-adapter>, ["~> 1.0.2"])
55  
-      s.add_development_dependency(%q<rspec>, ["~> 1.3"])
  51
+      s.add_development_dependency(%q<dm-migrations>, ["~> 1.0.2"])
  52
+      s.add_development_dependency(%q<rake>, ["~> 0.8.7"])
  53
+      s.add_development_dependency(%q<rspec>, ["~> 1.3.1"])
  54
+      s.add_development_dependency(%q<jeweler>, ["~> 1.5.2"])
56 55
     else
57 56
       s.add_dependency(%q<do_postgres>, ["~> 0.10.2"])
58 57
       s.add_dependency(%q<dm-do-adapter>, ["~> 1.0.2"])
59  
-      s.add_dependency(%q<rspec>, ["~> 1.3"])
  58
+      s.add_dependency(%q<dm-migrations>, ["~> 1.0.2"])
  59
+      s.add_dependency(%q<rake>, ["~> 0.8.7"])
  60
+      s.add_dependency(%q<rspec>, ["~> 1.3.1"])
  61
+      s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
60 62
     end
61 63
   else
62 64
     s.add_dependency(%q<do_postgres>, ["~> 0.10.2"])
63 65
     s.add_dependency(%q<dm-do-adapter>, ["~> 1.0.2"])
64  
-    s.add_dependency(%q<rspec>, ["~> 1.3"])
  66
+    s.add_dependency(%q<dm-migrations>, ["~> 1.0.2"])
  67
+    s.add_dependency(%q<rake>, ["~> 0.8.7"])
  68
+    s.add_dependency(%q<rspec>, ["~> 1.3.1"])
  69
+    s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
65 70
   end
66 71
 end
67 72
 
3  tasks/spec.rake
@@ -35,7 +35,4 @@ rescue LoadError
35 35
   end
36 36
 end
37 37
 
38  
-task :spec => :check_dependencies
39  
-task :rcov => :check_dependencies
40  
-
41 38
 task :default => :spec

0 notes on commit 50899bc

Please sign in to comment.
Something went wrong with that request. Please try again.