Permalink
Browse files

Remove jeweler

  • Loading branch information...
1 parent d82fe10 commit cd22dc9421965e491a22d74418d1a34e88faaf12 @solnic solnic committed Nov 7, 2011
Showing with 28 additions and 84 deletions.
  1. +3 −4 Gemfile
  2. +1 −21 Rakefile
  3. +19 −59 dm-postgres-adapter.gemspec
  4. +5 −0 lib/dm-postgres-adapter/version.rb
View
@@ -1,6 +1,8 @@
require 'pathname'
-source 'http://rubygems.org'
+source :rubygems
+
+gemspec
SOURCE = ENV.fetch('SOURCE', :git).to_sym
REPO_POSTFIX = SOURCE == :path ? '' : '.git'
@@ -23,9 +25,6 @@ group :development do
SOURCE => "#{DATAMAPPER}/dm-migrations#{REPO_POSTFIX}",
:branch => CURRENT_BRANCH
- gem 'jeweler', '~> 1.6.4'
- gem 'rspec', '~> 1.3.2'
-
end
platforms :mri_18 do
View
@@ -1,24 +1,4 @@
require 'rubygems'
require 'rake'
-begin
- gem 'jeweler', '~> 1.6.4'
- require 'jeweler'
-
- Jeweler::Tasks.new do |gem|
- gem.name = 'dm-postgres-adapter'
- gem.summary = 'PostgreSQL Adapter for DataMapper'
- gem.description = gem.summary
- gem.email = 'dan.kubb@gmail.com'
- gem.homepage = 'http://github.com/datamapper/%s' % gem.name
- gem.authors = [ 'Dan Kubb' ]
-
- gem.rubyforge_project = 'datamapper'
- end
-
- Jeweler::GemcutterTasks.new
-
- FileList['tasks/**/*.rake'].each { |task| import task }
-rescue LoadError
- puts 'Jeweler (or a dependency) not available. Install it with: gem install jeweler -v 1.6.4'
-end
+FileList['tasks/**/*.rake'].each { |task| import task }
@@ -1,65 +1,25 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
+require File.expand_path('../lib/dm-postgres-adapter/version', __FILE__)
-Gem::Specification.new do |s|
- s.name = "dm-postgres-adapter"
- s.version = "1.3.0.beta"
+Gem::Specification.new do |gem|
+ gem.name = 'dm-postgres-adapter'
+ gem.summary = 'PostgreSQL Adapter for DataMapper'
+ gem.description = gem.summary
+ gem.email = 'dan.kubb@gmail.com'
+ gem.homepage = 'http://datamapper.org'
+ gem.authors = [ 'Dan Kubb' ]
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Dan Kubb"]
- s.date = "2011-10-09"
- s.description = "PostgreSQL Adapter for DataMapper"
- s.email = "dan.kubb@gmail.com"
- s.extra_rdoc_files = [
- "LICENSE"
- ]
- s.files = [
- "Gemfile",
- "LICENSE",
- "Rakefile",
- "VERSION",
- "dm-postgres-adapter.gemspec",
- "lib/dm-postgres-adapter.rb",
- "lib/dm-postgres-adapter/adapter.rb",
- "lib/dm-postgres-adapter/spec/setup.rb",
- "spec/adapter_spec.rb",
- "spec/rcov.opts",
- "spec/spec.opts",
- "spec/spec_helper.rb",
- "tasks/spec.rake",
- "tasks/yard.rake",
- "tasks/yardstick.rake"
- ]
- s.homepage = "http://github.com/datamapper/dm-postgres-adapter"
- s.require_paths = ["lib"]
- s.rubyforge_project = "datamapper"
- s.rubygems_version = "1.8.11"
- s.summary = "PostgreSQL Adapter for DataMapper"
+ gem.files = `git ls-files`.split("\n")
+ gem.test_files = `git ls-files -- {spec}/*`.split("\n")
+ gem.extra_rdoc_files = %w[LICENSE]
- if s.respond_to? :specification_version then
- s.specification_version = 3
+ gem.require_paths = [ "lib" ]
+ gem.version = DataMapper::PostgresAdapter::VERSION
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.3.0.beta') then
- s.add_runtime_dependency(%q<do_postgres>, ["~> 0.10.6"])
- s.add_runtime_dependency(%q<dm-do-adapter>, ["~> 1.3.0.beta"])
- s.add_development_dependency(%q<dm-migrations>, ["~> 1.3.0.beta"])
- s.add_development_dependency(%q<jeweler>, ["~> 1.6.4"])
- s.add_development_dependency(%q<rspec>, ["~> 1.3.2"])
- else
- s.add_dependency(%q<do_postgres>, ["~> 0.10.6"])
- s.add_dependency(%q<dm-do-adapter>, ["~> 1.3.0.beta"])
- s.add_dependency(%q<dm-migrations>, ["~> 1.3.0.beta"])
- s.add_dependency(%q<jeweler>, ["~> 1.6.4"])
- s.add_dependency(%q<rspec>, ["~> 1.3.2"])
- end
- else
- s.add_dependency(%q<do_postgres>, ["~> 0.10.6"])
- s.add_dependency(%q<dm-do-adapter>, ["~> 1.3.0.beta"])
- s.add_dependency(%q<dm-migrations>, ["~> 1.3.0.beta"])
- s.add_dependency(%q<jeweler>, ["~> 1.6.4"])
- s.add_dependency(%q<rspec>, ["~> 1.3.2"])
- end
-end
+ gem.add_runtime_dependency(%q<do_postgres>, ["~> 0.10.6"])
+ gem.add_runtime_dependency(%q<dm-do-adapter>, ["~> 1.3.0.beta"])
+ gem.add_development_dependency(%q<dm-migrations>, ["~> 1.3.0.beta"])
+ gem.add_development_dependency(%q<rspec>, ["~> 1.3.2"])
+ gem.add_development_dependency(%q<rake>, ["~>0.9.2"])
+end
@@ -0,0 +1,5 @@
+module DataMapper
+ module PostgresAdapter
+ VERSION = '1.3.0.beta'
+ end
+end

0 comments on commit cd22dc9

Please sign in to comment.