Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Version bump to 1.1.0.rc1

* Updated Gemfile format
* Updated Copyright year
  • Loading branch information...
commit 4ac651f23eb0c60d7d67f19acfaee883b9d57cfa 1 parent 1acd9b6
@dkubb dkubb authored
Showing with 33 additions and 32 deletions.
  1. +14 −13 Gemfile
  2. +1 −1  LICENSE
  3. +2 −2 README.rdoc
  4. +1 −1  VERSION
  5. +15 −15 dm-rails.gemspec
View
27 Gemfile
@@ -2,34 +2,35 @@ require 'pathname'
source 'http://rubygems.org'
-SOURCE = ENV['SOURCE'] ? ENV['SOURCE'].to_sym : :git
+SOURCE = ENV.fetch('SOURCE', :git).to_sym
REPO_POSTFIX = SOURCE == :path ? '' : '.git'
DATAMAPPER = SOURCE == :path ? Pathname(__FILE__).dirname.parent : 'http://github.com/datamapper'
DM_VERSION = '~> 1.0.2'
group :runtime do
- gem 'i18n', '~> 0.5.0'
- gem 'activesupport', '~> 3.0.4', :require => 'active_support'
- gem 'actionpack', '~> 3.0.4', :require => 'action_pack'
- gem 'railties', '~> 3.0.4', :require => 'rails'
+ gem 'actionpack', '~> 3.0.4', :require => 'action_pack'
+ gem 'activesupport', '~> 3.0.4', :require => 'active_support'
gem 'dm-core', DM_VERSION, SOURCE => "#{DATAMAPPER}/dm-core#{REPO_POSTFIX}"
gem 'dm-active_model', DM_VERSION, SOURCE => "#{DATAMAPPER}/dm-active_model#{REPO_POSTFIX}"
+ gem 'i18n', '~> 0.5.0'
+ gem 'railties', '~> 3.0.4', :require => 'rails'
end
group :development do
- gem 'rake', '~> 0.8.7'
- gem 'jeweler', '~> 1.5.2'
- gem 'rspec', '~> 1.3.1'
+ gem 'jeweler', '~> 1.5.2'
+ gem 'rake', '~> 0.8.7'
+ gem 'rspec', '~> 1.3.1'
+
end
-group :quality do # These gems contain rake tasks that check the quality of the source code
+group :quality do
- gem 'rcov', '~> 0.9.7', :platforms => :mri_18
- gem 'yard', '~> 0.5'
- gem 'yardstick', '~> 0.1'
+ gem 'rcov', '~> 0.9.7', :platforms => :mri_18
+ gem 'yard', '~> 0.5'
+ gem 'yardstick', '~> 0.1'
end
@@ -44,7 +45,7 @@ group :datamapper do
options = {}
options[:git] = "#{DATAMAPPER}/do#{REPO_POSTFIX}" if ENV['DO_GIT'] == 'true'
- gem 'data_objects', DO_VERSION, options.dup
+ gem 'data_objects', DO_VERSION, options.dup
do_adapters.each do |adapter|
adapter = 'sqlite3' if adapter == 'sqlite'
View
2  LICENSE
@@ -1,4 +1,4 @@
-Copyright (c) 2010-2010 The dm-rails team
+Copyright (c) 2011-2010 The dm-rails team
Permission is hereby granted, free of charge, to any person obtaining
a copy of this software and associated documentation files (the
View
4 README.rdoc
@@ -99,7 +99,7 @@ Using {bundler}[http://github.com/carlhuda/bundler] it's really easy to get an a
gem 'actionmailer', RAILS_VERSION, :require => 'action_mailer'
gem 'railties', RAILS_VERSION, :require => 'rails'
- gem 'dm-rails', '~> 1.0.3'
+ gem 'dm-rails', '~> 1.1.0.rc1'
gem 'dm-sqlite-adapter', DM_VERSION
# You can use any of the other available database adapters.
@@ -584,4 +584,4 @@ Thx to all contributors, every patch, big or small is very much appreciated!
== Copyright
-Copyright (c) 2010-2010 The dm-rails team. See {LICENSE}[http://github.com/datamapper/dm-rails/blob/master/LICENSE] for details.
+Copyright (c) 2011-2010 The dm-rails team. See {LICENSE}[http://github.com/datamapper/dm-rails/blob/master/LICENSE] for details.
View
2  VERSION
@@ -1,2 +1,2 @@
-1.0.4
+1.1.0.rc1
View
30 dm-rails.gemspec
@@ -5,11 +5,11 @@
Gem::Specification.new do |s|
s.name = %q{dm-rails}
- s.version = "1.0.4"
+ s.version = "1.1.0.rc1"
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = ["Martin Gamsjaeger (snusnu)", "Dan Kubb"]
- s.date = %q{2011-02-25}
+ s.date = %q{2011-02-28}
s.description = %q{Integrate DataMapper with Rails 3}
s.email = %q{gamsnjaga@gmail.com}
s.extra_rdoc_files = [
@@ -72,35 +72,35 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<i18n>, ["~> 0.5.0"])
- s.add_runtime_dependency(%q<activesupport>, ["~> 3.0.4"])
s.add_runtime_dependency(%q<actionpack>, ["~> 3.0.4"])
- s.add_runtime_dependency(%q<railties>, ["~> 3.0.4"])
+ s.add_runtime_dependency(%q<activesupport>, ["~> 3.0.4"])
s.add_runtime_dependency(%q<dm-core>, ["~> 1.0.2"])
s.add_runtime_dependency(%q<dm-active_model>, ["~> 1.0.2"])
- s.add_development_dependency(%q<rake>, ["~> 0.8.7"])
+ s.add_runtime_dependency(%q<i18n>, ["~> 0.5.0"])
+ s.add_runtime_dependency(%q<railties>, ["~> 3.0.4"])
s.add_development_dependency(%q<jeweler>, ["~> 1.5.2"])
+ s.add_development_dependency(%q<rake>, ["~> 0.8.7"])
s.add_development_dependency(%q<rspec>, ["~> 1.3.1"])
else
- s.add_dependency(%q<i18n>, ["~> 0.5.0"])
- s.add_dependency(%q<activesupport>, ["~> 3.0.4"])
s.add_dependency(%q<actionpack>, ["~> 3.0.4"])
- s.add_dependency(%q<railties>, ["~> 3.0.4"])
+ s.add_dependency(%q<activesupport>, ["~> 3.0.4"])
s.add_dependency(%q<dm-core>, ["~> 1.0.2"])
s.add_dependency(%q<dm-active_model>, ["~> 1.0.2"])
- s.add_dependency(%q<rake>, ["~> 0.8.7"])
+ s.add_dependency(%q<i18n>, ["~> 0.5.0"])
+ s.add_dependency(%q<railties>, ["~> 3.0.4"])
s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
+ s.add_dependency(%q<rake>, ["~> 0.8.7"])
s.add_dependency(%q<rspec>, ["~> 1.3.1"])
end
else
- s.add_dependency(%q<i18n>, ["~> 0.5.0"])
- s.add_dependency(%q<activesupport>, ["~> 3.0.4"])
s.add_dependency(%q<actionpack>, ["~> 3.0.4"])
- s.add_dependency(%q<railties>, ["~> 3.0.4"])
+ s.add_dependency(%q<activesupport>, ["~> 3.0.4"])
s.add_dependency(%q<dm-core>, ["~> 1.0.2"])
s.add_dependency(%q<dm-active_model>, ["~> 1.0.2"])
- s.add_dependency(%q<rake>, ["~> 0.8.7"])
+ s.add_dependency(%q<i18n>, ["~> 0.5.0"])
+ s.add_dependency(%q<railties>, ["~> 3.0.4"])
s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
+ s.add_dependency(%q<rake>, ["~> 0.8.7"])
s.add_dependency(%q<rspec>, ["~> 1.3.1"])
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.