Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Version bump to 1.0.0.rc1

  • Loading branch information...
commit 50ce00ed243713db9d8198644d6229d0a8043c13 1 parent 110ecdf
@dkubb dkubb authored
View
5 Gemfile
@@ -1,6 +1,7 @@
source 'http://rubygems.org'
DATAMAPPER = 'git://github.com/datamapper'
+DM_VERSION = '~> 1.0.0.rc1'
group :runtime do
@@ -12,8 +13,8 @@ group :runtime do
end
- gem 'dm-core', '~> 0.10.3', :git => "#{DATAMAPPER}/dm-core.git"
- gem 'dm-active_model', '~> 0.4', :git => "#{DATAMAPPER}/dm-active_model.git"
+ gem 'dm-core', DM_VERSION, :git => "#{DATAMAPPER}/dm-core.git"
+ gem 'dm-active_model', '~> 0.4', :git => "#{DATAMAPPER}/dm-active_model.git"
end
View
18 README.rdoc
@@ -116,21 +116,21 @@ Using {bundler}[http://github.com/carlhuda/bundler] it's really easy to get an a
git 'git://github.com/snusnu/dm-core.git', 'branch' => 'active_support'
git "git://github.com/snusnu/dm-more.git", 'branch' => 'active_support'
- gem 'dm-core', '~> 0.10.2'
- gem 'dm-types', '~> 0.10.2'
- gem 'dm-validations', '~> 0.10.2'
- gem 'dm-constraints', '~> 0.10.2'
- gem 'dm-aggregates', '~> 0.10.2'
- gem 'dm-timestamps', '~> 0.10.2'
- gem 'dm-migrations', '~> 0.10.2'
- gem 'dm-observer', '~> 0.10.2'
+ gem 'dm-core', '~> 1.0.0.rc1'
+ gem 'dm-types', '~> 1.0.0.rc1'
+ gem 'dm-validations', '~> 1.0.0.rc1'
+ gem 'dm-constraints', '~> 1.0.0.rc1'
+ gem 'dm-aggregates', '~> 1.0.0.rc1'
+ gem 'dm-timestamps', '~> 1.0.0.rc1'
+ gem 'dm-migrations', '~> 1.0.0.rc1'
+ gem 'dm-observer', '~> 1.0.0.rc1'
# Use this instead of git if you're working on dm-rails
# path '/full/path/to/your/local/clone/of/dm-rails'
git 'git://github.com/datamapper/dm-rails.git'
- gem 'dm-rails', '~> 0.10.2'
+ gem 'dm-rails', '~> 1.0.0.rc1'
git 'git://github.com/rspec/rspec.git'
git 'git://github.com/rspec/rspec-core.git'
View
2  Rakefile
@@ -14,7 +14,7 @@ begin
gem.homepage = 'http://github.com/datamapper/dm-rails'
gem.authors = [ 'Martin Gamsjaeger (snusnu)', 'Dan Kubb' ]
- gem.add_dependency 'dm-core', '~> 0.10.2'
+ gem.add_dependency 'dm-core', '~> 1.0.0.rc1'
gem.add_dependency 'dm-active_model', '~> 0.4'
gem.add_dependency 'activesupport', '~> 3.0.0.beta3'
View
2  VERSION
@@ -1 +1 @@
-0.10.2
+1.0.0.rc1
View
15 dm-rails.gemspec
@@ -5,11 +5,11 @@
Gem::Specification.new do |s|
s.name = %q{dm-rails}
- s.version = "0.10.2"
+ s.version = "1.0.0.rc1"
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = ["Martin Gamsjaeger (snusnu)", "Dan Kubb"]
- s.date = %q{2010-05-18}
+ s.date = %q{2010-05-19}
s.description = %q{Integrate DataMapper with Rails 3}
s.email = %q{gamsnjaga@gmail.com}
s.extra_rdoc_files = [
@@ -62,27 +62,24 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<dm-core>, ["~> 0.10.2"])
+ s.add_runtime_dependency(%q<dm-core>, ["~> 1.0.0.rc1"])
s.add_runtime_dependency(%q<dm-active_model>, ["~> 0.4"])
s.add_runtime_dependency(%q<activesupport>, ["~> 3.0.0.beta3"])
s.add_runtime_dependency(%q<actionpack>, ["~> 3.0.0.beta3"])
s.add_runtime_dependency(%q<railties>, ["~> 3.0.0.beta3"])
- s.add_development_dependency(%q<yard>, ["~> 0.5"])
else
- s.add_dependency(%q<dm-core>, ["~> 0.10.2"])
+ s.add_dependency(%q<dm-core>, ["~> 1.0.0.rc1"])
s.add_dependency(%q<dm-active_model>, ["~> 0.4"])
s.add_dependency(%q<activesupport>, ["~> 3.0.0.beta3"])
s.add_dependency(%q<actionpack>, ["~> 3.0.0.beta3"])
s.add_dependency(%q<railties>, ["~> 3.0.0.beta3"])
- s.add_dependency(%q<yard>, ["~> 0.5"])
end
else
- s.add_dependency(%q<dm-core>, ["~> 0.10.2"])
+ s.add_dependency(%q<dm-core>, ["~> 1.0.0.rc1"])
s.add_dependency(%q<dm-active_model>, ["~> 0.4"])
s.add_dependency(%q<activesupport>, ["~> 3.0.0.beta3"])
s.add_dependency(%q<actionpack>, ["~> 3.0.0.beta3"])
s.add_dependency(%q<railties>, ["~> 3.0.0.beta3"])
- s.add_dependency(%q<yard>, ["~> 0.5"])
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.