Skip to content

Loading…

Deprecation warnings with rake 0.9.0 #10

Open
adamtrilling opened this Issue · 3 comments

3 participants

@adamtrilling

I just built a new dev environment, and ended up with the brand-new rake 0.9.0. It causes some deprecation warnings in dm-rails:

WARNING: 'task :t, arg, :needs => [deps]' is deprecated. Please use 'task :t, [args] => [deps]' instead.
at /dm-rails-1.1.0/lib/dm-rails/railties/database.rake:67
WARNING: 'task :t, arg, :needs => [deps]' is deprecated. Please use 'task :t, [args] => [deps]' instead.
at /dm-rails-1.1.0/lib/dm-rails/railties/database.rake:72

Not sure if you can fix these without breaking any intended backwards compatibility, but just in case you wanted to know...

@mltsy

Yeah, I'm getting this now too, with the new rake.

@shadowbq

Check out dm-rails for rails 3.0 and dm 1.1.1

git clone git://github.com/datamapper/dm-rails.git
git checkout 196f37ac90

Rake is 0.8 and RSPEC is 1.* in Bundle

  • DontBundle Install it points at HEAD of DM
rake build 
sudo gem install pkg/dm-rails-1.1.1.gem
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.