Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Remove jeweler

  • Loading branch information...
commit 3489025195baf89ee7d96b8358c5317566d057e3 1 parent 213bf39
@solnic solnic authored
View
11 Gemfile
@@ -1,6 +1,8 @@
require 'pathname'
-source 'http://rubygems.org'
+source :rubygems
+
+gemspec
SOURCE = ENV.fetch('SOURCE', :git).to_sym
REPO_POSTFIX = SOURCE == :path ? '' : '.git'
@@ -13,16 +15,9 @@ gem 'dm-serializer', DM_VERSION,
:branch => CURRENT_BRANCH
group :development do
-
gem 'dm-validations', DM_VERSION,
SOURCE => "#{DATAMAPPER}/dm-validations#{REPO_POSTFIX}",
:branch => CURRENT_BRANCH
-
- gem 'fakeweb', '~> 1.3'
- gem 'jeweler', '~> 1.6.4'
- gem 'rake', '~> 0.9.2'
- gem 'rspec', '~> 1.3.2'
-
end
platforms :mri_18 do
View
22 Rakefile
@@ -1,24 +1,4 @@
require 'rubygems'
require 'rake'
-begin
- gem 'jeweler', '~> 1.6.4'
- require 'jeweler'
-
- Jeweler::Tasks.new do |gem|
- gem.name = 'dm-rest-adapter'
- gem.summary = 'REST Adapter for DataMapper'
- gem.description = gem.summary
- gem.email = 'scott.burton [a] joyent [d] com'
- gem.homepage = 'http://github.com/datamapper/%s' % gem.name
- gem.authors = [ 'Scott Burton @ Joyent Inc' ]
-
- gem.rubyforge_project = 'datamapper'
- end
-
- Jeweler::GemcutterTasks.new
-
- FileList['tasks/**/*.rake'].each { |task| import task }
-rescue LoadError
- puts 'Jeweler (or a dependency) not available. Install it with: gem install jeweler -v 1.6.4'
-end
+FileList['tasks/**/*.rake'].each { |task| import task }
View
88 dm-rest-adapter.gemspec
@@ -1,76 +1,24 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
+require File.expand_path('../lib/dm-rest-adapter/version', __FILE__)
-Gem::Specification.new do |s|
- s.name = "dm-rest-adapter"
- s.version = "1.3.0.beta"
+Gem::Specification.new do |gem|
+ gem.authors = [ 'Scott Burton @ Joyent Inc' ]
+ gem.email = [ 'scott.burton [a] joyent [d] com' ]
+ gem.summary = 'REST Adapter for DataMapper'
+ gem.description = gem.summary
+ gem.homepage = "http://datamapper.org"
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Scott Burton @ Joyent Inc"]
- s.date = "2011-10-09"
- s.description = "REST Adapter for DataMapper"
- s.email = "scott.burton [a] joyent [d] com"
- s.extra_rdoc_files = [
- "LICENSE",
- "README.rdoc"
- ]
- s.files = [
- "Gemfile",
- "LICENSE",
- "README.rdoc",
- "Rakefile",
- "VERSION",
- "dm-rest-adapter.gemspec",
- "lib/dm-rest-adapter.rb",
- "lib/dm-rest-adapter/adapter.rb",
- "lib/dm-rest-adapter/connection.rb",
- "lib/dm-rest-adapter/exceptions.rb",
- "lib/dm-rest-adapter/formats.rb",
- "lib/dm-rest-adapter/spec/setup.rb",
- "spec/fixtures/book.rb",
- "spec/fixtures/difficult_book.rb",
- "spec/rcov.opts",
- "spec/semipublic/connection_spec.rb",
- "spec/semipublic/rest_adapter_spec.rb",
- "spec/spec.opts",
- "spec/spec_helper.rb",
- "tasks/spec.rake",
- "tasks/yard.rake",
- "tasks/yardstick.rake"
- ]
- s.homepage = "http://github.com/datamapper/dm-rest-adapter"
- s.require_paths = ["lib"]
- s.rubyforge_project = "datamapper"
- s.rubygems_version = "1.8.11"
- s.summary = "REST Adapter for DataMapper"
+ gem.files = `git ls-files`.split("\n")
+ gem.test_files = `git ls-files -- {spec}/*`.split("\n")
+ gem.extra_rdoc_files = %w[LICENSE README.rdoc]
- if s.respond_to? :specification_version then
- s.specification_version = 3
+ gem.name = 'dm-rest-adapter'
+ gem.require_paths = [ "lib" ]
+ gem.version = DataMapper::RestAdapter::VERSION
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.3.0.beta') then
- s.add_runtime_dependency(%q<dm-serializer>, ["~> 1.3.0.beta"])
- s.add_development_dependency(%q<dm-validations>, ["~> 1.3.0.beta"])
- s.add_development_dependency(%q<fakeweb>, ["~> 1.3"])
- s.add_development_dependency(%q<jeweler>, ["~> 1.6.4"])
- s.add_development_dependency(%q<rake>, ["~> 0.9.2"])
- s.add_development_dependency(%q<rspec>, ["~> 1.3.2"])
- else
- s.add_dependency(%q<dm-serializer>, ["~> 1.3.0.beta"])
- s.add_dependency(%q<dm-validations>, ["~> 1.3.0.beta"])
- s.add_dependency(%q<fakeweb>, ["~> 1.3"])
- s.add_dependency(%q<jeweler>, ["~> 1.6.4"])
- s.add_dependency(%q<rake>, ["~> 0.9.2"])
- s.add_dependency(%q<rspec>, ["~> 1.3.2"])
- end
- else
- s.add_dependency(%q<dm-serializer>, ["~> 1.3.0.beta"])
- s.add_dependency(%q<dm-validations>, ["~> 1.3.0.beta"])
- s.add_dependency(%q<fakeweb>, ["~> 1.3"])
- s.add_dependency(%q<jeweler>, ["~> 1.6.4"])
- s.add_dependency(%q<rake>, ["~> 0.9.2"])
- s.add_dependency(%q<rspec>, ["~> 1.3.2"])
- end
-end
+ gem.add_runtime_dependency('dm-serializer', '~> 1.3.0.beta')
+ gem.add_development_dependency('rake', '~> 0.9.2')
+ gem.add_development_dependency('rspec', '~> 1.3.2')
+ gem.add_development_dependency('fakeweb', '~> 1.3')
+end
View
5 lib/dm-rest-adapter/version.rb
@@ -0,0 +1,5 @@
+module DataMapper
+ module RestAdapter
+ VERSION = '1.3.0.beta'
+ end
+end
Please sign in to comment.
Something went wrong with that request. Please try again.