Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Updated Gemfile and gemspec

  • Loading branch information...
commit 98a54f2999c585e0070f491fea81d048be5dc956 1 parent dd60937
@dkubb dkubb authored
Showing with 18 additions and 34 deletions.
  1. +17 −27 Gemfile
  2. +1 −7 dm-tags.gemspec
View
44 Gemfile
@@ -2,23 +2,14 @@ require 'pathname'
source 'http://rubygems.org'
-SOURCE = ENV.fetch('SOURCE', :git).to_sym
-REPO_POSTFIX = SOURCE == :path ? '' : '.git'
-DATAMAPPER = SOURCE == :path ? Pathname(__FILE__).dirname.parent : 'http://github.com/datamapper'
-DM_VERSION = '~> 1.1.0.rc1'
-
-group :runtime do
-
- if ENV['EXTLIB']
- gem 'extlib', '~> 0.9.15', SOURCE => "#{DATAMAPPER}/extlib#{REPO_POSTFIX}", :require => nil
- else
- gem 'activesupport', '~> 3.0.4', :require => nil
- gem 'i18n', '~> 0.5.0'
- end
-
- gem 'dm-core', DM_VERSION, SOURCE => "#{DATAMAPPER}/dm-core#{REPO_POSTFIX}"
+SOURCE = ENV.fetch('SOURCE', :git).to_sym
+REPO_POSTFIX = SOURCE == :path ? '' : '.git'
+DATAMAPPER = SOURCE == :path ? Pathname(__FILE__).dirname.parent : 'http://github.com/datamapper'
+DM_VERSION = '~> 1.1.0.rc1'
+DO_VERSION = '~> 0.10.2'
+DM_DO_ADAPTERS = %w[ sqlite postgres mysql oracle sqlserver ]
-end
+gem 'dm-core', DM_VERSION, SOURCE => "#{DATAMAPPER}/dm-core#{REPO_POSTFIX}"
group :development do
@@ -29,12 +20,14 @@ group :development do
end
-group :quality do
+platforms :mri_18 do
+ group :quality do
- gem 'rcov', '~> 0.9.9', :platforms => :mri_18
- gem 'yard', '~> 0.6'
- gem 'yardstick', '~> 0.2'
+ gem 'rcov', '~> 0.9.9'
+ gem 'yard', '~> 0.6'
+ gem 'yardstick', '~> 0.2'
+ end
end
group :datamapper do
@@ -42,18 +35,15 @@ group :datamapper do
adapters = ENV['ADAPTER'] || ENV['ADAPTERS']
adapters = adapters.to_s.tr(',', ' ').split.uniq - %w[ in_memory ]
- DO_VERSION = '~> 0.10.2'
- DM_DO_ADAPTERS = %w[ sqlite postgres mysql oracle sqlserver ]
-
if (do_adapters = DM_DO_ADAPTERS & adapters).any?
- options = {}
- options[:git] = "#{DATAMAPPER}/do#{REPO_POSTFIX}" if ENV['DO_GIT'] == 'true'
+ do_options = {}
+ do_options[:git] = "#{DATAMAPPER}/do#{REPO_POSTFIX}" if ENV['DO_GIT'] == 'true'
- gem 'data_objects', DO_VERSION, options.dup
+ gem 'data_objects', DO_VERSION, do_options.dup
do_adapters.each do |adapter|
adapter = 'sqlite3' if adapter == 'sqlite'
- gem "do_#{adapter}", DO_VERSION, options.dup
+ gem "do_#{adapter}", DO_VERSION, do_options.dup
end
gem 'dm-do-adapter', DM_VERSION, SOURCE => "#{DATAMAPPER}/dm-do-adapter#{REPO_POSTFIX}"
View
8 dm-tags.gemspec
@@ -9,7 +9,7 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = ["Bobby Calderwood"]
- s.date = %q{2011-02-28}
+ s.date = %q{2011-03-01}
s.description = %q{This package brings tagging to DataMapper. It is inspired by Acts As Taggable On by Michael Bleigh, github's mbleigh. Props to him for the contextual tagging based on Acts As Taggable on Steroids.}
s.email = %q{bobby_calderwood [a] me [d] com}
s.extra_rdoc_files = [
@@ -57,16 +57,12 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<activesupport>, ["~> 3.0.4"])
- s.add_runtime_dependency(%q<i18n>, ["~> 0.5.0"])
s.add_runtime_dependency(%q<dm-core>, ["~> 1.1.0.rc1"])
s.add_development_dependency(%q<dm-validations>, ["~> 1.1.0.rc1"])
s.add_development_dependency(%q<jeweler>, ["~> 1.5.2"])
s.add_development_dependency(%q<rake>, ["~> 0.8.7"])
s.add_development_dependency(%q<rspec>, ["~> 1.3.1"])
else
- s.add_dependency(%q<activesupport>, ["~> 3.0.4"])
- s.add_dependency(%q<i18n>, ["~> 0.5.0"])
s.add_dependency(%q<dm-core>, ["~> 1.1.0.rc1"])
s.add_dependency(%q<dm-validations>, ["~> 1.1.0.rc1"])
s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
@@ -74,8 +70,6 @@ Gem::Specification.new do |s|
s.add_dependency(%q<rspec>, ["~> 1.3.1"])
end
else
- s.add_dependency(%q<activesupport>, ["~> 3.0.4"])
- s.add_dependency(%q<i18n>, ["~> 0.5.0"])
s.add_dependency(%q<dm-core>, ["~> 1.1.0.rc1"])
s.add_dependency(%q<dm-validations>, ["~> 1.1.0.rc1"])
s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
Please sign in to comment.
Something went wrong with that request. Please try again.