Patch 1.2.0 to play nicely with Formtastic #54

Open
nathanl opened this Issue Mar 23, 2012 · 0 comments

Comments

Projects
None yet
1 participant

nathanl commented Mar 23, 2012

Formtastic is able to infer from ActiveRecord models which fields are required and mark them with an asterisk. It is not able to do this with DM 1.2.0. (marks all fields as required). However, the following monkeypatch makes it work in our app.

What would be the best way to contribute this, given that you're now working on 1.3.0 and 2.0?

module DataMapper::Validations::ClassMethods
  def validators_on(attribute)
    validators[attribute.to_sym] || []
  end
end

class DataMapper::Validations::GenericValidator
  def self.kind
    @kind ||= name.split('::').last.sub(/Validator$/, '').downcase.to_sym
  end

  def kind
    self.class.kind
  end
end
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment