Skip to content

PostgreSQL

Alex Coles edited this page Apr 10, 2011 · 1 revision

README

I'm starting this description although it does not work yet. Maybe someone can help in figuring this out :)

For Ruby 1.9 you can try to build the "next" branch from the github repository. You need to have Cygwin (for wget, curl and unzip executables) as well as Mingw. Both installations bin directories must be on the path.

First of all you need rake-compiler: gem install rake-compiler

Then you can go ahead and checkout and build the gem:

git clone git://github.com/datamapper/do.git
git checkout -b next origin/next
cd do
cd do_postgres
rake gem
gem install pkg\do_postgres-0.10.1.gem -- --with-pgsql-win32-dir="C:\Program Files\PostgreSQL\8.4"

This gives the following error:

checking for main() in -lpq... yes
checking for libpq-fe.h... yes
checking for libpq/libpq-fs.h... yes
checking for postgres.h... no
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

I tried copying the postgres.h file from the PostgreSql sources but that yields the same error.

Hopefully anyone has a better clue than me...

Something went wrong with that request. Please try again.