Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 28 lines (21 sloc) 0.753 kb
925352a1 »
2008-05-22 Adding Rakefile copied from dm-core.
1 require 'rubygems'
2 require 'rake'
3
3f23656c »
2009-11-24 Converted to use Jeweler
4 begin
f4195105 »
2011-02-19 Updated Rakefile to use jeweler 1.5.2
5 gem 'jeweler', '~> 1.5.2'
3f23656c »
2009-11-24 Converted to use Jeweler
6 require 'jeweler'
7c83011d »
2008-08-01 Make Extlib use new release task.
7
3f23656c »
2009-11-24 Converted to use Jeweler
8 Jeweler::Tasks.new do |gem|
9 gem.name = 'extlib'
10 gem.summary = 'Support library for DataMapper and Merb'
11 gem.description = gem.summary
12 gem.email = 'dan.kubb@gmail.com'
13 gem.homepage = 'http://github.com/datamapper/extlib'
14 gem.authors = [ 'Dan Kubb' ]
1906d1cd »
2008-07-18 Hoeing extlib.
15
3f23656c »
2009-11-24 Converted to use Jeweler
16 gem.rubyforge_project = 'extlib'
7c83011d »
2008-08-01 Make Extlib use new release task.
17
0b5d9a44 »
2010-05-18 Updated json_pure dependency to ~> 1.4
18 gem.add_development_dependency 'json_pure', '~> 1.4'
43477178 »
2010-02-01 Bump dependency versions
19 gem.add_development_dependency 'rspec', '~> 1.3'
925352a1 »
2008-05-22 Adding Rakefile copied from dm-core.
20 end
2a32e6ef »
2008-11-06 Stripped whitespace
21
3f23656c »
2009-11-24 Converted to use Jeweler
22 Jeweler::GemcutterTasks.new
c3dfaa01 »
2009-11-26 Load tasks only if Jeweler is installed
23
24 FileList['tasks/**/*.rake'].each { |task| load task }
3f23656c »
2009-11-24 Converted to use Jeweler
25 rescue LoadError
f4195105 »
2011-02-19 Updated Rakefile to use jeweler 1.5.2
26 puts 'Jeweler (or a dependency) not available. Install it with: gem install jeweler -v 1.5.2'
109ec6b8 »
2008-09-14 Minor updates to improve ruby 1.9 compatibility
27 end
Something went wrong with that request. Please try again.