Permalink
Browse files

YAML::Tiny suddenly is broken

It expects decoded data as input
  • Loading branch information...
datamuc committed Feb 17, 2014
1 parent 5451fc9 commit 8551a0a1857329d91349b29240d9dd59041c277c
Showing with 3 additions and 3 deletions.
  1. +1 −1 Makefile.PL
  2. +2 −2 lib/Mojolicious/Plugin/YamlConfig.pm
View
@@ -19,7 +19,7 @@ WriteMakefile(
'NAME' => 'Mojolicious::Plugin::YamlConfig',
'PREREQ_PM' => {
'Mojolicious' => '1.80',
- 'YAML::Tiny' => '0'
+ 'YAML::Tiny' => '1.60'
},
META_ADD => {
resources => {
@@ -5,7 +5,7 @@ package Mojolicious::Plugin::YamlConfig;
use base 'Mojolicious::Plugin::JSONConfig';
-our $VERSION = '0.1.6';
+our $VERSION = '0.1.7';
sub register {
my ( $self, $app, $conf ) = @_;
@@ -31,7 +31,7 @@ sub parse {
# Render
$content = $self->render($content, $file, $conf, $app);
- my @broken = qw(YAML YAML::Old);
+ my @broken = qw(YAML YAML::Old YAML::Tiny);
if (grep { $class eq $_ } @broken) {
# they are broken *sigh*
$content = Encode::decode('UTF-8', $content);

0 comments on commit 8551a0a

Please sign in to comment.