Skip to content

Make java-driver 2.0 compatible with DSE 3.x authentication #159

Merged
merged 1 commit into from Mar 4, 2014

2 participants

@beobal
DataStax member
beobal commented Mar 3, 2014
  • In Connection, if v1 but authenticator is not a ProtocolV1Authenticator, attempt v2 authentication
  • Revised (de)coders in Auth* messages as they may be used in a v1 context (by DSE 3.x)
@pcmanus pcmanus merged commit e32c7c4 into datastax:2.0 Mar 4, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.