Skip to content
Permalink
master
Switch branches/tags
Go to file
 
 
Cannot retrieve contributors at this time
{
"name": "dat",
"version": "14.0.2",
"description": "Dat is the package manager for data. Easily share and version control data.",
"keywords": [
"dat",
"dat protocol",
"hyperdrive",
"decentralized",
"file sharing"
],
"main": "index.js",
"bin": {
"dat": "bin/cli.js"
},
"scripts": {
"auth-server": "DEBUG=* node scripts/auth-server.js",
"install-precommit": "echo ./node_modules/.bin/standard > .git/hooks/pre-commit && chmod +x .git/hooks/pre-commit",
"standard": "standard",
"deps": "dependency-check . && dependency-check . --extra --no-dev",
"test": "standard && npm run deps && tape 'test/*.js'",
"test-only": "tape 'test/*.js'",
"package": "rm -rf builds && npm run pkg && ./package.sh",
"pkg": "pkg package.json -o builds/dat"
},
"repository": {
"type": "git",
"url": "git://github.com/datproject/dat.git"
},
"author": "Dat Project",
"license": "BSD-3-Clause",
"bugs": {
"url": "https://github.com/datproject/dat/issues"
},
"homepage": "https://datproject.org",
"directories": {
"test": "tests"
},
"dependencies": {
"bytes": "^3.1.0",
"chalk": "^2.4.2",
"cli-truncate": "^1.0.0",
"dat-encoding": "^5.0.1",
"dat-json": "^1.0.3",
"dat-link-resolve": "^2.3.0",
"dat-log": "^2.0.0",
"dat-node": "^4.0.0",
"dat-registry": "^4.0.1",
"debug": "^4.0.0",
"neat-log": "^3.1.0",
"prettier-bytes": "^1.0.3",
"progress-string": "^1.2.1",
"prompt": "^1.0.0",
"pump": "^3.0.0",
"rimraf": "^2.7.1",
"speedometer": "^1.1.0",
"subcommand": "^2.1.1",
"throttle": "^1.0.3",
"update-notifier": "^2.3.0"
},
"devDependencies": {
"cross-zip-cli": "^1.0.0",
"dependency-check": "^3.4.1",
"hypercore": "^6.25.2",
"mkdirp": "^0.5.4",
"node-fetch": "^2.6.1",
"pkg": "^4.4.4",
"random-access-memory": "^3.1.1",
"recursive-readdir-sync": "^1.0.6",
"standard": "^12.0.0",
"tape": "^4.13.2",
"tape-spawn": "^1.4.2",
"temporary-directory": "^1.0.2"
},
"pkg": {
"assets": [
"./node_modules/utp-native/prebuilds/**",
"./node_modules/blake2b-wasm/blake2b.wasm",
"./node_modules/siphash24/siphash24.wasm"
],
"targets": [
"node10-linux-x64",
"node10-macos-x64",
"node10-win-x64"
]
}
}