Permalink
Fetching contributors…
Cannot retrieve contributors at this time
62 lines (42 sloc) 1.43 KB

Installing datreant

You can install datreant from PyPI using pip:

pip install datreant

It is also possible to use --user to install into your user's site-packages directory:

pip install --user datreant

Alternatively we also provide conda package.

conda install -c datreant datreant

All datreant packages currently support the following Python versions:

- 2.7
- 3.3
- 3.4
- 3.5
- 3.6

Dependencies

The dependencies of datreant are light, with many being pure-Python packages themselves. The current dependencies are:

- asciitree
- pathlib
- scandir
- six
- fuzzywuzzy
- python-Levenshtein

These are automatically installed when installing datreant.

Installing from source

To install from source, clone the repository and switch to the master branch

git clone git@github.com:datreant/datreant.git
cd datreant
git checkout master

Installation of the packages is as simple as

pip install .

This installs datreant in the system wide python directory; this may require administrative privileges. If you have a virtualenv active, it will install the package within your virtualenv. See :ref:`Development_env` for more on setting up a proper development environment.

It is also possible to use --user to install into your user's site-packages directory:

pip install --user .