Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Updated ruote dependency.

  • Loading branch information...
commit 5d519d0c0e8b9e0b6930652bd8780f42c52bb9f2 1 parent d14f5b6
David Austin authored
View
1  Rakefile
@@ -16,6 +16,7 @@ begin
gemspec.add_dependency "right_aws", ">=1.10.0"
gemspec.add_dependency "activesupport", ">=2.3.4"
gemspec.add_dependency "activerecord", ">=2.3.4"
+ gemspec.add_dependency "ruote", "=2.1.7"
gemspec.add_dependency "json", ">=1.2.0"
gemspec.add_dependency "amqp", "=0.6.7"
gemspec.add_dependency "daemon-kit", "=0.1.8pre"
View
7 config/initializers/qips-node-amqp.rb
@@ -6,6 +6,13 @@
end
begin
+ require 'ruote'
+rescue LoadError
+ $stderr.puts "Missing ruote gem. Please run 'gem install ruote'"
+ exit 1
+end
+
+begin
require 'amqp'
require 'mq'
rescue LoadError
View
28 qips-node-amqp.gemspec
@@ -5,11 +5,11 @@
Gem::Specification.new do |s|
s.name = %q{qips-node-amqp}
- s.version = "0.7.1"
+ s.version = "0.7.3"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["David Austin", "Andrew Brader"]
- s.date = %q{2010-07-30}
+ s.date = %q{2010-08-23}
s.description = %q{Listens for jobs on a rabbit server, works closely with qipr-rmgr}
s.email = %q{daustin@mail.med.upenn.edu}
s.executables = ["qips-node-amqp", "status-updater.rb"]
@@ -86,9 +86,33 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+ s.add_runtime_dependency(%q<right_aws>, [">= 1.10.0"])
+ s.add_runtime_dependency(%q<activesupport>, [">= 2.3.4"])
+ s.add_runtime_dependency(%q<activerecord>, [">= 2.3.4"])
+ s.add_runtime_dependency(%q<ruote>, ["= 2.1.7"])
+ s.add_runtime_dependency(%q<json>, [">= 1.2.0"])
+ s.add_runtime_dependency(%q<amqp>, ["= 0.6.7"])
+ s.add_runtime_dependency(%q<daemon-kit>, ["= 0.1.8pre"])
+ s.add_runtime_dependency(%q<rest-client>, ["= 1.5.1"])
else
+ s.add_dependency(%q<right_aws>, [">= 1.10.0"])
+ s.add_dependency(%q<activesupport>, [">= 2.3.4"])
+ s.add_dependency(%q<activerecord>, [">= 2.3.4"])
+ s.add_dependency(%q<ruote>, ["= 2.1.7"])
+ s.add_dependency(%q<json>, [">= 1.2.0"])
+ s.add_dependency(%q<amqp>, ["= 0.6.7"])
+ s.add_dependency(%q<daemon-kit>, ["= 0.1.8pre"])
+ s.add_dependency(%q<rest-client>, ["= 1.5.1"])
end
else
+ s.add_dependency(%q<right_aws>, [">= 1.10.0"])
+ s.add_dependency(%q<activesupport>, [">= 2.3.4"])
+ s.add_dependency(%q<activerecord>, [">= 2.3.4"])
+ s.add_dependency(%q<ruote>, ["= 2.1.7"])
+ s.add_dependency(%q<json>, [">= 1.2.0"])
+ s.add_dependency(%q<amqp>, ["= 0.6.7"])
+ s.add_dependency(%q<daemon-kit>, ["= 0.1.8pre"])
+ s.add_dependency(%q<rest-client>, ["= 1.5.1"])
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.