Permalink
Browse files

Added more debug ginfo useful for prod runs

  • Loading branch information...
1 parent 17bad94 commit b85b9a613246f92613b511f3d7f7365e3429675b David Austin committed Oct 5, 2010
Showing with 11 additions and 3 deletions.
  1. +6 −1 lib/worker.rb
  2. +5 −2 qips-node-amqp.gemspec
View
7 lib/worker.rb
@@ -96,7 +96,12 @@ def start_work
if (! workitem.params['executable'].nil?) && (File.exist?(which_exec))
- out = `#{workitem.params['executable']} #{args} #{infiles_arg}`
+ resp = Net::HTTP.get_response(URI.parse(META_URL))
+ instance_id = resp.body
+ instance_id = 'UNKNOWN' if instance_id.size > 50
+
+ out = "\nInstance ID: #{instance_id}\nRunning: #{workitem.params['executable']} #{args} #{infiles_arg}\nWorkflow id: #{workitem.fei['wfid']}\n\n"
+ out += `#{workitem.params['executable']} #{args} #{infiles_arg}`
DaemonKit.logger.info "Found output:"
puts out
View
7 qips-node-amqp.gemspec
@@ -5,11 +5,11 @@
Gem::Specification.new do |s|
s.name = %q{qips-node-amqp}
- s.version = "0.7.10"
+ s.version = "0.7.11"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["David Austin", "Andrew Brader"]
- s.date = %q{2010-09-01}
+ s.date = %q{2010-09-30}
s.description = %q{Listens for jobs on a rabbit server, works closely with qipr-rmgr}
s.email = %q{daustin@mail.med.upenn.edu}
s.executables = ["qips-node-amqp", "status-updater.rb"]
@@ -94,6 +94,7 @@ Gem::Specification.new do |s|
s.add_runtime_dependency(%q<amqp>, ["= 0.6.7"])
s.add_runtime_dependency(%q<daemon-kit>, ["= 0.1.8pre"])
s.add_runtime_dependency(%q<rest-client>, ["= 1.5.1"])
+ s.add_runtime_dependency(%q<mzml>, [">= 0.1.0"])
else
s.add_dependency(%q<right_aws>, [">= 1.10.0"])
s.add_dependency(%q<activesupport>, ["= 2.3.5"])
@@ -103,6 +104,7 @@ Gem::Specification.new do |s|
s.add_dependency(%q<amqp>, ["= 0.6.7"])
s.add_dependency(%q<daemon-kit>, ["= 0.1.8pre"])
s.add_dependency(%q<rest-client>, ["= 1.5.1"])
+ s.add_dependency(%q<mzml>, [">= 0.1.0"])
end
else
s.add_dependency(%q<right_aws>, [">= 1.10.0"])
@@ -113,6 +115,7 @@ Gem::Specification.new do |s|
s.add_dependency(%q<amqp>, ["= 0.6.7"])
s.add_dependency(%q<daemon-kit>, ["= 0.1.8pre"])
s.add_dependency(%q<rest-client>, ["= 1.5.1"])
+ s.add_dependency(%q<mzml>, [">= 0.1.0"])
end
end

0 comments on commit b85b9a6

Please sign in to comment.