Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Adding README and more test files

  • Loading branch information...
commit 4afb742d2f60704830216a880fa63f086145451e 1 parent 2ae1b4f
@davglass authored
View
42 README.textile
@@ -0,0 +1,42 @@
+h1. YUI Development Combo Server
+
+This php script is designed to help while developing and debugging yui.
+
+Not only is it a local combo handler, it will also allow you to pull and combo specific tags from git.
+
+h2. Example
+
+<pre class="console">
+<script type="text/javascript" src="index.php?yui3-1292/build/yui/yui-min.js"></script>
+<script type="text/javascript">
+YUI({
+ comboBase: 'index.php?',
+ combine: true
+}).use('node', function(Y) {
+ Y.on('domready', function() {
+ Y.get('body').setStyle('backgroundColor', 'green').set('innerHTML', 'YUI 3.x tag ' + YUI.version + ' loaded.');
+ });
+});
+</script>
+</pre>
+
+or
+
+<pre class="console">
+<script type="text/javascript" src="index.php?yui2-2164/build/yuiloader/yuiloader-min.js"></script>
+<script type="text/javascript">
+var loader = new YAHOO.util.YUILoader({
+ comboBase: 'index.php?',
+ combine: true,
+ require: ['event', 'dom'],
+ onSuccess: function() {
+ YAHOO.util.Dom.setStyle(document.body, 'background-color', 'green');
+ document.body.innerHTML = 'YUI 2.x version ' + YAHOO.VERSION + ' loaded.';
+ }
+});
+loader.insert();
+</script>
+</pre>
+
+
+This package has only been tested on a Mac, but it should run under Linux ;)
View
6 install.sh
@@ -95,9 +95,9 @@ echo "Installation complete."
echo ""
echo "------------------------------------------------------------------------------------------"
echo ""
-echo "Now put the index.php and test.php files under your web root, then open the test.php file."
-echo "You can try test.php to load YUI 3.0.0b1"
-echo "Then try test.php?version=yui3-1291 to load the yui3-1291 tag."
+echo "Now put the index.php and test.php files under your web root, then open the test-yui3.php file."
+echo "You can try test-yui3.php to load YUI 3.0.0b1"
+echo "Then try test-yui3.php?version=yui3-1291 to load the yui3-1291 tag."
echo ""
echo "------------------------------------------------------------------------------------------"
echo ""
View
25 test-yui2.php
@@ -0,0 +1,25 @@
+<?php
+$version = (($_GET['version']) ? $_GET['version'] : '2.7.0');
+?>
+<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
+<html>
+<head>
+ <title>2.x local combo test</title>
+ <script type="text/javascript" src="index.php?<?php echo($version); ?>/build/yuiloader/yuiloader-min.js"></script>
+ <script type="text/javascript">
+ var loader = new YAHOO.util.YUILoader({
+ comboBase: 'index.php?',
+ combine: true,
+ require: ['event', 'dom'],
+ onSuccess: function() {
+ YAHOO.util.Dom.setStyle(document.body, 'background-color', 'green');
+ document.body.innerHTML = 'YUI 2.x version ' + YAHOO.VERSION + ' loaded.';
+ }
+ });
+ loader.insert();
+ </script>
+</head>
+<body>
+</body>
+</html>
+
View
23 test-yui3.php
@@ -0,0 +1,23 @@
+<?php
+$version = (($_GET['version']) ? $_GET['version'] : '3.0.0b1');
+?>
+<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
+<html>
+<head>
+ <title>3.x local combo test</title>
+ <script type="text/javascript" src="index.php?<?php echo($version); ?>/build/yui/yui-min.js"></script>
+ <script type="text/javascript">
+ YUI({
+ comboBase: 'index.php?',
+ combine: true
+ }).use('node', function(Y) {
+ Y.on('domready', function() {
+ Y.get('body').setStyle('backgroundColor', 'green').set('innerHTML', 'YUI 3.x tag ' + YUI.version + ' loaded.');
+ });
+ });
+ </script>
+</head>
+<body>
+</body>
+</html>
+
View
23 test.php
@@ -1,23 +0,0 @@
-<?php
-$version = (($_GET['version']) ? $_GET['version'] : '3.0.0b1');
-?>
-<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
-<html>
-<head>
- <title>3.x local combo test</title>
-</head>
-<body>
-<script type="text/javascript" src="index.php?<?php echo($version); ?>/build/yui/yui-min.js"></script>
-<script type="text/javascript">
-YUI({
- comboBase: 'http://dev-combo.davglass.com/?',
- combine: true
-}).use('node', function(Y) {
- Y.on('domready', function() {
- Y.get('body').setStyle('backgroundColor', 'green').set('innerHTML', 'YUI 3.x tag ' + YUI.version + ' loaded.');
- });
-});
-</script>
-</body>
-</html>
-
Please sign in to comment.
Something went wrong with that request. Please try again.