Permalink
Browse files

Remove 1.8.7 from Travis, add 2.1.0

Signed-off-by: David Celis <me@davidcel.is>
  • Loading branch information...
1 parent dd9e9dc commit 2f698f6304ef83e341baa5365770eec40c6b4fb8 @davidcelis committed Jan 9, 2014
Showing with 4 additions and 3 deletions.
  1. +2 −1 .travis.yml
  2. +2 −2 README.md
View
@@ -2,10 +2,10 @@ language: ruby
services:
- redis-server
rvm:
- - 1.8.7
- 1.9.2
- 1.9.3
- 2.0.0
+ - 2.1.0
- jruby-19mode
gemfile:
- gemfiles/rails_31.gemfile
@@ -17,3 +17,4 @@ matrix:
gemfile: gemfiles/rails_40.gemfile
- rvm: 1.9.2
gemfile: gemfiles/rails_40.gemfile
+script: bundle exec rake test
View
@@ -4,7 +4,7 @@ Recommendable is a gem that allows you to quickly add a recommendation engine fo
## Requirements
-* Ruby 1.9.x or 2.0.0. 1.8.7 works, but is no longer supported.
+* Ruby >= 1.9.3
* ActiveRecord, Sequel, DataMapper, Mongoid, or MongoMapper (your models must have an `id` field)
* [Sidekiq][sidekiq], [Resque][resque], [DelayedJob][delayed-job] (optional but highly recommended)
@@ -18,7 +18,7 @@ Add the following to your application's `Gemfile`:
gem 'recommendable'
```
-Please note that you currently must need to place Recommendable below your ORM and queueing system in the Gemfile. If you are using Sidekiq and ActiveRecord, please place `gem recommendable` below both `gem 'rails'` and `gem 'sidekiq'`.
+Please note that you currently must need to place Recommendable below your ORM and queueing system in the Gemfile. If you are using Sidekiq and ActiveRecord, please place `gem recommendable` below both `gem 'rails'` and `gem 'sidekiq'`.
After bundling, you should configure Recommendable. Do this somewhere after you've required it, but before it's actually used. For example, Rails users would create an initializer (`config/initializers/recommendable.rb`):

0 comments on commit 2f698f6

Please sign in to comment.