Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

c3.whatsapp.net not working #171

Closed
mkolchin opened this issue Oct 30, 2014 · 93 comments
Closed

c3.whatsapp.net not working #171

mkolchin opened this issue Oct 30, 2014 · 93 comments

Comments

@mkolchin
Copy link

@mkolchin mkolchin commented Oct 30, 2014

Server closed the connection

@mkolchin mkolchin changed the title c3.whatsapp.net is down c3.whatsapp.net not working Oct 30, 2014
@SebiPanther
Copy link

@SebiPanther SebiPanther commented Nov 7, 2014

I've the same Problem. I've tryed to use yowsup-cli instead of whatsapp-purple. I've tryed to request a new code. But the server denied my request with the message "blocked". :/

@OGGolan
Copy link

@OGGolan OGGolan commented Nov 13, 2014

I've the same problem also. have you had any success fixing it?

@rutja76
Copy link

@rutja76 rutja76 commented Nov 13, 2014

Same here as of today, cannot connect to c3.whatsapp.net

@ThYpHo0n
Copy link

@ThYpHo0n ThYpHo0n commented Nov 13, 2014

Same here, don't have the time right now to check wireshark but i think they've changed their protocol again... and are now blocking any different requests /o\

@davidgfnet
Copy link
Owner

@davidgfnet davidgfnet commented Nov 13, 2014

I used it yesterday, actually 9 hours ago.... Anyone got it working?

@giordano
Copy link
Contributor

@giordano giordano commented Nov 13, 2014

It doesn't work for me: "Server closed the connection"

@ThYpHo0n
Copy link

@ThYpHo0n ThYpHo0n commented Nov 13, 2014

Yesterday evening/night it was all fine here but since this morning it can't connect anymore. I've also tried different proxies (US, FR, DE).

@mlopezgva
Copy link

@mlopezgva mlopezgva commented Nov 13, 2014

Same here, last connection 2014-11-12 19:57 GMT.
Tried getting a new password, but it didn't solve the issue.

@KottV
Copy link

@KottV KottV commented Nov 13, 2014

does not work [c c1 c2] .whatsapp.net, even with port 5222

@mlopezgva
Copy link

@mlopezgva mlopezgva commented Nov 13, 2014

I've changed Android version from 2.1 to 2.3 and voilà, I'm on-line again... :)
Please, try it and comment here!

@KottV
Copy link

@KottV KottV commented Nov 13, 2014

mlopezgva
no luck :(
what did actually you typed in version field?

@mlopezgva
Copy link

@mlopezgva mlopezgva commented Nov 13, 2014

Actually, I requested a new password and put it in, then changed server from c3.w... to c2.w... and changed Android version from 2.1[..] to 2.3[..], that's all the changes I made.

@giordano
Copy link
Contributor

@giordano giordano commented Nov 13, 2014

Actually, I requested a new password and put it in, then changed server from c3.w... to c2.w... and changed Android version from 2.1[..] to 2.3[..], that's all the changes I made.

I set default_resource to "Android-2.31.151-443" and WHATSAPP_DEFAULT_SERVER to "c2.whatsapp.net", but I still cannot connect.

@KottV
Copy link

@KottV KottV commented Nov 13, 2014

wow! thank you, change to 2.31.151-443 works
and using c2. whatsapp.net for now

@ThYpHo0n
Copy link

@ThYpHo0n ThYpHo0n commented Nov 13, 2014

Can confirm, changing Android version and server to c2 works!

@rutja76
Copy link

@rutja76 rutja76 commented Nov 13, 2014

Confirming here as well: it works with 2.31.151-443 and c2.whatsapp.net, port unchanged

@giordano
Copy link
Contributor

@giordano giordano commented Nov 13, 2014

Sorry, I recompiled the plugin but server and resource are stored in accounts.xml, now I can confirm I can connect changing those settings with values suggested by @mlopezgva.

@davidgfnet
Copy link
Owner

@davidgfnet davidgfnet commented Nov 13, 2014

Thanks for the info. I might have different Android version on my computer
since I usually backup my custom config.

Do you feel like creating a pull request for the default config?
Thanks!

@angelbladex
Copy link

@angelbladex angelbladex commented Nov 13, 2014

O_o i can't connect today

(09:55:37) proxy: Connecting to c3.whatsapp.net:443 with no proxy
(09:55:37) proxy: Connection in progress
(09:55:37) proxy: Connecting to c3.whatsapp.net:443.
(09:55:37) proxy: Connected to c3.whatsapp.net:443.
(09:55:38) connection: Connection error on 0x8ddfe48 (reason: 0 description: Server closed the connection)
(09:55:38) account: Disconnecting account 58########## (0x##########)
(09:55:38) connection: Disconnecting connection 0x8ddfe48
(09:55:38) connection: Destroying connection 0x8ddfe48

I read , Whatsapp was suspending users who dont use oficial app [Spanish] > http://www.somosblackberry.com/whatsapp-suspende-las-cuentas-de-los-usuarios-que-usan-la-aplicacion-oficial/

i did changes as metioned and nothing
How works?

accounts -> Your Whattapp account -> Advanced
Change resourse to Android-2.31.151-443 .
For any reason dont change this value via compilation :S

The change is required on ~/.purple/accounts.xml if file exist
if apply grep, get this

grep Android accounts.xml
Android-2.31.151-443

@ducklin5
Copy link

@ducklin5 ducklin5 commented Nov 13, 2014

Thanks! changing of android version and server works!

@matadi
Copy link

@matadi matadi commented Nov 13, 2014

Thanks, confirm that it works after changes (Windows - pigdin plugin)!

@giordano
Copy link
Contributor

@giordano giordano commented Nov 13, 2014

For what is worth, the plugin can connect using resource and server before commit 45fbbbb.

@deanet
Copy link

@deanet deanet commented Nov 14, 2014

changing of android version and server works too...

thanks

This was referenced Nov 14, 2014
@grobi68
Copy link

@grobi68 grobi68 commented Nov 14, 2014

G R E A T ! ! ! Thanks for this help!
Works on Windows and on Linux.
Just changed Android version, not the server (still using c3...)

@Azhturion
Copy link

@Azhturion Azhturion commented Nov 14, 2014

@angelbladex
grep Android accounts.xml
Android-2.31.151-443

It works!! Thanks!!

@styxtwo
Copy link

@styxtwo styxtwo commented Nov 14, 2014

Confirmed,
c2.whatsapp.net
and
Android-2.31.151-443
did the trick

@tijelino
Copy link

@tijelino tijelino commented Apr 23, 2015

Server: S 40-2.12.11-443 (with the space between the S and the 4)

worked for me in spain

@SergeyDjam
Copy link

@SergeyDjam SergeyDjam commented Apr 23, 2015

work now. Russia

@mkolchin
Copy link
Author

@mkolchin mkolchin commented Apr 24, 2015

How do you get it?

@mkolchin
Copy link
Author

@mkolchin mkolchin commented Apr 24, 2015

connection: Connection error on 0x85834c8 (reason: 2 description: not-authorized)

@davidgfnet
Copy link
Owner

@davidgfnet davidgfnet commented Apr 24, 2015

@mkolchin
Copy link
Author

@mkolchin mkolchin commented Apr 24, 2015

@mkolchin
Copy link
Author

@mkolchin mkolchin commented Apr 24, 2015

Thanks it worked!

@yatahid
Copy link

@yatahid yatahid commented May 6, 2015

WhatsApp on Pidgin can't connect
Server closed the connection

@yatahid
Copy link

@yatahid yatahid commented May 6, 2015

WhatsApp on Pidgin can't connect
Server closed the connection
Resource: Android-2.31.151-443

@erwin68
Copy link

@erwin68 erwin68 commented Jul 20, 2015

My system ubuntu 12.04
Did WA-Registration with yowsup.
Then installed pidgin and whatsapp-purple.
Then it worked fine for one evening.

Next day at starting up pidgin I got "not-authorized".
But logon with yowsup worked fine.
Then I only changed Resource to Android-2.31.151-443 an pidgin worked again.

Seems that "not-authorized" indicated not that my number was blocked or that the number/password was wrong but "client is not accepted"

@KottV
Copy link

@KottV KottV commented Jul 20, 2015

I just found, that c1 c2 c3 whatsapp.net became unreachable, so I searched for their servers addresses, and typed first random 184.173.136.66
now it connects, so far

@davidgfnet
Copy link
Owner

@davidgfnet davidgfnet commented Jul 20, 2015

@KottV C* servers are no longer used. Look at the source. Use E instead. Leaving the box empty will use a random server.

@KottV
Copy link

@KottV KottV commented Jul 20, 2015

oh, news
excuse me, what is "E" ? :)
and I tried with empty "server" fields now, unsuccesfull

@davidgfnet
Copy link
Owner

@davidgfnet davidgfnet commented Jul 20, 2015

@KottV
Copy link

@KottV KottV commented Jul 20, 2015

understand, thnx

@frenton
Copy link

@frenton frenton commented Jul 20, 2015

I switched server to

e1.whatsapp.net:443

but still getting exception

"Fatal error: Uncaught exception 'Exception' with message 'Login Failure' in ..."

even though the number is not blocked. I checked it using WART repeatedly. Does anybody know, what might be the problem?

EDIT: solved by updating Anroid version to 2.31.151

@angelbladex
Copy link

@angelbladex angelbladex commented Jul 20, 2015

Ahhh i was having problems for use the plugin, i change versión to Android-2.31.151-443 and solved. I was thinking my account was blocked but i changed my password vía yowsup and my account was OK

@davidgfnet
Copy link
Owner

@davidgfnet davidgfnet commented Jul 21, 2015

@ghost
Copy link

@ghost ghost commented Jul 21, 2015

Yes, just installed. Had the error to connect. Changed the Android version. Connection stated.
Messages do arrive at recipients, but no messages received as response. (Despite them sending ;-) .)

@davidgfnet
Copy link
Owner

@davidgfnet davidgfnet commented Jul 21, 2015

That might depend on how you got your password. Getting passwords through Android resources/devices will use encryption and you won't be able to read messages. Re-activate it using S40

@ghost
Copy link

@ghost ghost commented Jul 21, 2015

? Reactivate it using S40? (Small how-to, please?) OS btw: Ubuntu 15.04.

@ghost
Copy link

@ghost ghost commented Jul 21, 2015

Or do you mean: S 40-2.12.11-443 in Account setting -> Advanced -> Resource?

@ghost
Copy link

@ghost ghost commented Jul 22, 2015

Unfortunately, tried several advanced account configs, no solution so far.

@qohelet
Copy link

@qohelet qohelet commented Aug 1, 2015

I started to use WhatsApp via Pidgin yesterday (installed via apt-get). I could send messages but was never able to receive anything. I am located in Uzbekistan and tried the app before on a Nokia 301.1 then on a Wexler.Tab 7iD with Android 4.1.1 - both worked fine.

My settings:
Server: e1.whatsapp.net
Resource: Android-2.31.151-443

Before I tried the old Server c2.whatsapp.net - no changes.
Strangely I can see my friends typing. Yet no message ever reached me - but everything which was sent to me is shown as read.

Even more strangely: It's no problem to receive pictures.

I'm carefully trying now something else:
Resource: Android-4.1.1
Nickname: Qohelet

No changes - yet strange. Apparently it's not so important what's standing there. I assume it might be just needed to change it once to acknowledge WhatsApp "something" happened.

Ideas?

@legolasbdn
Copy link

@legolasbdn legolasbdn commented Aug 12, 2015

Hi there,

I have the same issue than qohelet, i'm from spain if that helps.

Thank you.

@vinipsmaker
Copy link

@vinipsmaker vinipsmaker commented Aug 20, 2015

I cannot connect anymore. I've tried lots of approaches. I'm from Brazil, if that helps. -.-"

@KottV
Copy link

@KottV KottV commented Aug 21, 2015

I've got some trouble yesterday. Then I updated yowsup from git, run ./yowsup-cli registration -p "number" -C "code" -r sms

now it works

@vinipsmaker
Copy link

@vinipsmaker vinipsmaker commented Aug 31, 2015

Then I updated yowsup from git, run ./yowsup-cli registration -p "number" -C "code" -r sms

now it works

It worked here too.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
You can’t perform that action at this time.