If you support Python 3, tell it in the setup.py #194

Closed
goinnn opened this Issue Apr 5, 2013 · 4 comments

Comments

Projects
None yet
2 participants

goinnn commented Apr 5, 2013

The classifiers should be:
"Programming Language :: Python :: 2",
"Programming Language :: Python :: 3",

Collaborator

dbrgn commented Apr 5, 2013

Python 3.3 is currently still failing: https://travis-ci.org/davidhalter/jedi And Python 3.0/3.1 are not supported at all.

Maybe we should list the supported minor versions explicitly?

Programming Language :: Python :: 2
Programming Language :: Python :: 2.6
Programming Language :: Python :: 2.7
Programming Language :: Python :: 3
Programming Language :: Python :: 3.2

goinnn commented Apr 5, 2013

I think so, This is better. Thanks!

Collaborator

dbrgn commented Apr 5, 2013

Actually Python 3.3 support was just merged: #187 Travis is failing though.

Collaborator

dbrgn commented Apr 5, 2013

Done in dev branch. Will go into next PyPI release.

@dbrgn dbrgn closed this Apr 5, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment