Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Version bump to 0.2.0

  • Loading branch information...
commit 449017ec9e0f0e7bb73f62ca0b9b487e1aadce01 1 parent 3a2f0f5
Daz Oakley authored
Showing with 20 additions and 9 deletions.
  1. +7 −0 History.txt
  2. +1 −1  Rakefile
  3. +11 −7 biomart.gemspec
  4. +1 −1  lib/biomart.rb
View
7 History.txt
@@ -1,3 +1,10 @@
+=== 0.2.0 2010-06-10
+
+* 2 major enhancements:
+ * Added the ability to perform federated queries across two datasets.
+ * Added the option to discard rows of data if a specified list of
+ fields are not present.
+
=== 0.1.5 2010-02-04
* 1 major bugfix:
View
2  Rakefile
@@ -20,7 +20,7 @@ $hoe = Hoe.spec "biomart" do
self.summary = "A ruby API for interacting with Biomart services."
self.description = "A ruby API for interacting with Biomart XML based webservices."
self.extra_deps = [["builder",">= 0"]]
- self.extra_dev_deps = [["thoughtbot-shoulda",">=0"]]
+ self.extra_dev_deps = [["shoulda",">= 2.10"]]
self.extra_rdoc_files = ["README.rdoc"]
end
View
18 biomart.gemspec
@@ -2,12 +2,12 @@
Gem::Specification.new do |s|
s.name = %q{biomart}
- s.version = "0.1.5"
+ s.version = "0.2.0"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Darren Oakley"]
- s.date = %q{2010-02-04}
- s.description = %q{A ruby API for interacting with Biomart services.}
+ s.date = %q{2010-06-10}
+ s.description = %q{A ruby API for interacting with Biomart XML based webservices.}
s.email = ["daz.oakley@gmail.com"]
s.extra_rdoc_files = ["History.txt", "Manifest.txt", "README.rdoc"]
s.files = ["History.txt", "Manifest.txt", "README.rdoc", "Rakefile", "biomart.gemspec", "lib/biomart.rb", "lib/biomart/attribute.rb", "lib/biomart/database.rb", "lib/biomart/dataset.rb", "lib/biomart/filter.rb", "lib/biomart/server.rb", "script/console", "script/destroy", "script/generate", "tasks/metrics.task", "tasks/shoulda.task", "test/test_biomart.rb", "test/test_helper.rb"]
@@ -15,7 +15,7 @@ Gem::Specification.new do |s|
s.rdoc_options = ["--main", "README.rdoc"]
s.require_paths = ["lib"]
s.rubyforge_project = %q{biomart}
- s.rubygems_version = %q{1.3.5}
+ s.rubygems_version = %q{1.3.7}
s.summary = %q{A ruby API for interacting with Biomart services.}
s.test_files = ["test/test_biomart.rb", "test/test_helper.rb"]
@@ -23,14 +23,18 @@ Gem::Specification.new do |s|
current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 3
- if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
+ if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<builder>, [">= 0"])
- s.add_development_dependency(%q<thoughtbot-shoulda>, [">= 0"])
- s.add_development_dependency(%q<hoe>, [">= 2.3.3"])
+ s.add_development_dependency(%q<shoulda>, [">= 2.10"])
+ s.add_development_dependency(%q<hoe>, [">= 2.6.1"])
else
s.add_dependency(%q<builder>, [">= 0"])
+ s.add_dependency(%q<shoulda>, [">= 2.10"])
+ s.add_dependency(%q<hoe>, [">= 2.6.1"])
end
else
s.add_dependency(%q<builder>, [">= 0"])
+ s.add_dependency(%q<shoulda>, [">= 2.10"])
+ s.add_dependency(%q<hoe>, [">= 2.6.1"])
end
end
View
2  lib/biomart.rb
@@ -8,7 +8,7 @@
require "builder"
module Biomart
- VERSION = "0.1.5"
+ VERSION = "0.2.0"
# This is the base Biomart error/exception class. Rescue it if
# you want to catch any exceptions that this code might raise.
Please sign in to comment.
Something went wrong with that request. Please try again.