Skip to content
DronePan - 360 aerial panoramas with DJI Inspire 1, Phantom 3/4, Mavic Pro and Osmo
Branch: master
Clone or download
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
DronePan.xcodeproj
DronePan
DronePanTests
assets App icon work Mar 11, 2016
scripts Re-add remote logging Nov 18, 2016
.gitattributes Adding gitattributes for DJI SDK framework Nov 21, 2016
.gitignore
.slather.yml Local slather config May 14, 2016
.travis.yml
CHANGELOG.md
Cartfile
Cartfile.resolved
LICENSE.md
Makefile
README.md
codecov.yml

README.md

Join the chat at https://gitter.im/dbaldwin/DronePan Build Status codecov Tag Issues GPLv3

DronePan

DronePan - 360 aerial panoramas with DJI (Phantom (3 and later), Inspire, Matrice, Mavic, Osmo family)

Download on the App Store

As of 6th March 2016 DronePan is open source.

  • For bugs, feature requests etc - please use the project issues page.

Want to help out?

If you want to help out then there are several things you can do:

  • Come talk to us on gitter.im
  • Fork the project and send in pull requests
  • Create issues if you have a problem/bug or suggestion

Want to beta test?

For iOS we use TestFlight from Apple. To sign up - please fill out the following form

It's not working!?!?!

OK - that's not good. And we'd like to help.

But! We do need to know what's not working.

Some basic info we need:

  • What actually happened? "It didn't work" doesn't give us a lot to go on
  • What version of DronePan are you running - see Settings (lower right corner)
  • What DJI device are you running and which firmware is it on
  • What does the DronePan log say - see Settings > Copy log to clipboard (lower left corner)

It's best to grab a copy of that log right after it didn't work. We don't want to use up a lot of space on your device so it won't hang around for too long.

Facebook

Join our Facebook group here: http://www.facebook.com/groups/dronepan

Development

Tools in use:

  • XCode (surprise)
  • Carthage to handle dependencies
  • git-lfs because the DJI SDK is too large for the repo on github

To clone - make sure you have git-lfs installed before you clone.

This is easiest with homebrew:

brew install git git-lfs

Your clone command will look like this:

git lfs clone https://github.com/dbaldwin/DronePan

After cloning - you'll need to run:

carthage bootstrap --platform ios
You can’t perform that action at this time.