Permalink
Browse files

Do not require pysqlite2 on EL6 since it is already included as sqlite3

  • Loading branch information...
1 parent da399e9 commit b948a1f14b6c8fe37bf3854019cd2cd65330635f @sciurus sciurus committed Jul 30, 2012
@@ -5,7 +5,7 @@
Name: graphite-web
Version: 0.9.10
-Release: 1
+Release: 2
Summary: Enterprise scalable realtime graphing
Group: Applications/Internet
License: Apache License
@@ -21,7 +21,8 @@ Patch4: graphite-web-python24compat.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: python python-devel python-setuptools
-Requires: Django django-tagging httpd mod_wsgi pycairo python-sqlite2 python-simplejson
+Requires: Django django-tagging httpd mod_wsgi pycairo python-simplejson
+%{?el5:Requires: python-sqlite2}
%description
Graphite consists of a storage backend and a web-based visualization frontend.
@@ -116,6 +117,9 @@ CFLAGS="$RPM_OPT_FLAGS" %{__python} -c 'import setuptools; execfile("setup.py")'
%ghost %{_localstatedir}/lib/%{name}/graphite.db
%changelog
+* Mon Jul 30 2012 Brian Pitts <brian@polibyte.com> - 0.9.10-2
+- Do not require pysqlite2 on EL6 since it is already included as sqlite3
+
* Fri Jun 1 2012 Ben P <ben@g.megatron.org> - 0.9.10-1
- New upstream version.
@@ -5,7 +5,7 @@
Name: graphite-web
Version: 0.9.8
-Release: 2
+Release: 3
Summary: Enterprise scalable realtime graphing
Group: Applications/Internet
License: Apache License
@@ -19,7 +19,8 @@ Patch1: graphite-config.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: python python-devel python-setuptools
-Requires: Django httpd mod_wsgi pycairo python-sqlite2
+Requires: Django httpd mod_wsgi pycairo
+%{?el5:Requires: python-sqlite2}
%description
Graphite consists of a storage backend and a web-based visualization frontend.
@@ -103,6 +104,9 @@ CFLAGS="$RPM_OPT_FLAGS" %{__python} -c 'import setuptools; execfile("setup.py")'
%ghost %{_localstatedir}/lib/%{name}/graphite.db
%changelog
+* Mon Jul 30 2012 Brian Pitts <brian@polibyte.com> - 0.9.10-2
+- Do not require pysqlite2 on EL6 since it is already included as sqlite3
+
* Mon May 23 2011 Dan Carley <dan.carley@gmail.com> - 0.9.8-2
- Repackage with some tidying.
- Move state directory to /var/lib
@@ -5,7 +5,7 @@
Name: graphite-web
Version: 0.9.9
-Release: 1
+Release: 2
Summary: Enterprise scalable realtime graphing
Group: Applications/Internet
License: Apache License
@@ -20,7 +20,8 @@ Patch3: graphite-web-wsgi.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: python python-devel python-setuptools
-Requires: Django django-tagging httpd mod_wsgi pycairo python-sqlite2 python-simplejson
+Requires: Django django-tagging httpd mod_wsgi pycairo python-simplejson
+%{?el5:Requires: python-sqlite2}
%description
Graphite consists of a storage backend and a web-based visualization frontend.
@@ -114,6 +115,9 @@ CFLAGS="$RPM_OPT_FLAGS" %{__python} -c 'import setuptools; execfile("setup.py")'
%ghost %{_localstatedir}/lib/%{name}/graphite.db
%changelog
+* Mon Jul 30 2012 Brian Pitts <brian@polibyte.com> - 0.9.10-2
+- Do not require pysqlite2 on EL6 since it is already included as sqlite3
+
* Sat Oct 8 2011 Dan Carley <dan.carley@gmail.com> - 0.9.9-1
- New upstream version.

0 comments on commit b948a1f

Please sign in to comment.