Permalink
Browse files

release 1.1.11

  • Loading branch information...
1 parent 270d626 commit 95245450ddb0511c266784d43f939f17019888fa @dchelimsky committed Oct 24, 2008
Showing with 9 additions and 24 deletions.
  1. +6 −0 History.txt
  2. +0 −1 Rakefile
  3. +1 −1 lib/spec/version.rb
  4. +2 −22 rspec.gemspec
View
@@ -1,3 +1,9 @@
+=== Version 1.1.11 / 2008-10-24
+
+* 1 major enhancement
+
+ * eliminate ALL gem dependencies (as they were causing trouble for people on different platforms/environments)
+
=== Version 1.1.10 / 2008-10-24
* 1 minor enhancement
View
@@ -18,7 +18,6 @@ Hoe.new('rspec', Spec::VERSION::STRING) do |p|
p.url = 'http://rspec.info/'
p.description = "Behaviour Driven Development for Ruby."
p.rubyforge_name = 'rspec'
- p.extra_dev_deps = ['diff-lcs','syntax']
p.developer('RSpec Development Team', 'rspec-devel@rubyforge.org')
p.remote_rdoc_dir = "rspec/#{Spec::VERSION::STRING}"
end
View
@@ -3,7 +3,7 @@ module VERSION
unless defined? MAJOR
MAJOR = 1
MINOR = 1
- TINY = 10
+ TINY = 11
STRING = [MAJOR, MINOR, TINY].join('.')
View
@@ -2,7 +2,7 @@
Gem::Specification.new do |s|
s.name = %q{rspec}
- s.version = "1.1.10"
+ s.version = "1.1.11"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["RSpec Development Team"]
@@ -18,25 +18,5 @@ Gem::Specification.new do |s|
s.require_paths = ["lib"]
s.rubyforge_project = %q{rspec}
s.rubygems_version = %q{1.3.0}
- s.summary = %q{rspec 1.1.10}
-
- if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
- s.specification_version = 2
-
- if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<diff-lcs>, [">= 0"])
- s.add_development_dependency(%q<syntax>, [">= 0"])
- s.add_development_dependency(%q<spicycode-rcov>, [">= 0.8.1.3"])
- s.add_development_dependency(%q<hoe>, [">= 1.8.1"])
- else
- s.add_dependency(%q<diff-lcs>, [">= 0"])
- s.add_dependency(%q<syntax>, [">= 0"])
- s.add_dependency(%q<hoe>, [">= 1.8.1"])
- end
- else
- s.add_dependency(%q<diff-lcs>, [">= 0"])
- s.add_dependency(%q<syntax>, [">= 0"])
- s.add_dependency(%q<hoe>, [">= 1.8.1"])
- end
+ s.summary = %q{rspec 1.1.11}
end

2 comments on commit 9524545

Contributor

sporkmonger replied Oct 30, 2008

Well, the way the gemspec code was written was wrong before. It should have been set up to fail for any version of RubyGems that didn’t respond to add_development_dependency. Older versions of the gem client can read the development dependencies, but don’t treat them differently. Only the person who builds the gems needs to be running the latest version. You don’t really want to be accidentally building gems with an old version, so it should fail if you try and let you know you need to upgrade to build the gem.

Contributor

sporkmonger replied Oct 30, 2008

That said, lest my previous comment be misinterpreted, this is a good change. :-D

Please sign in to comment.