Not looking for :focus in 2.8.0.rc1 #47

Closed
cj opened this Issue Dec 2, 2011 · 6 comments

Comments

Projects
None yet
4 participants

cj commented Dec 2, 2011

Hi,

RSpec is no longer looking for :focus in 2.8.0.rc1 it just runs all the tests even though I have a describe with :focus, it also no longer says it's even looking for focus. Here's my spec_helper.rb https://gist.github.com/455b7c83ae541f2f8bdf

Any help would be great.

Many thanks

skaufman commented Jan 9, 2012

Seems as if this may be an guard-rspec issue, not rspec per se. When running specs via guard, I also see that :focus isn't being used. But when running specs directly with rspec, only specs tagged with :focus run -- exactly the desired behavior.

tbor commented Jan 11, 2012

Yes, seems to be a problem with guard. I have the same issue.

Actually, it appears to be an issue with rspec 2.8.x -- not guard or spork. See this discussion:

sporkrb/spork#166

The simple workaround is to add --tag focus to your .rspec file, and filtering via :focus tags is restored.

tbor commented Jan 13, 2012

Very nice, thank you!

Owner

dchelimsky commented Jan 14, 2012

This is the tracker for rspec-1. Please report this to https://github.com/rspec/rspec-core/issues.

@dchelimsky dchelimsky closed this Jan 14, 2012

Owner

dchelimsky commented Jan 14, 2012

Actually I took the liberty of doing this myself: rspec/rspec-core#554

@dchelimsky dchelimsky referenced this issue in rspec/rspec-core Jan 14, 2012

Closed

Not looking for :focus in 2.8.0.rc1 #554

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment