New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

pbts install fails for tmp@^7.1.1 #612

Closed
jeffgrossmann opened this Issue Jan 3, 2017 · 0 comments

Comments

Projects
None yet
1 participant
@jeffgrossmann

jeffgrossmann commented Jan 3, 2017

protobuf.js version: 6.4.0

Running pbts after installing protobufjs@6.4.0 reports the following error.
jpg@ubuntu:~/pbtest$ ./node_modules/.bin/pbts
installing tmp@^7.1.1 ...
child_process.js:526
throw err;
^

Error: Command failed: npm --silent install tmp@^7.1.1

at checkExecSyncError (child_process.js:483:13)
at Object.execSync (child_process.js:523:13)
at Object.exports.require (/home/jpg/pbtest/node_modules/protobufjs/cli/util.js:86:23)
at Object.<anonymous> (/home/jpg/pbtest/node_modules/protobufjs/cli/pbts.js:10:21)
at Module._compile (module.js:570:32)
at Object.Module._extensions..js (module.js:579:10)
at Module.load (module.js:487:32)
at tryModuleLoad (module.js:446:12)
at Function.Module._load (module.js:438:3)
at Module.require (module.js:497:17)

Looking at the code, it a simple copy/paste error in cli/pbts.js, line 10.
pkg.devDependencies.glob should be pkg.devDependencies.tmp

The version number for glob is 7.1.1 while the latest version number for tmp is 0.0.31.

Manually running npm install tmp@^7.1.1 with-out the --silent reports....
jpg@ubuntu:~/pbtest$ npm install tmp@^7.1.1
npm ERR! Linux 4.4.0-53-generic
npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "install" "tmp@^7.1.1"
npm ERR! node v6.9.2
npm ERR! npm v3.10.9
npm ERR! code ETARGET

npm ERR! notarget No compatible version found: tmp@^7.1.1
npm ERR! notarget Valid install targets:
npm ERR! notarget 0.0.31, 0.0.30, 0.0.29, 0.0.28, 0.0.27, 0.0.26, 0.0.25, 0.0.24, 0.0.23, 0.0.22, 0.0.21, 0.0.20, 0.0.18, 0.0.17, 0.0.16, 0.0.15, 0.0.14, 0.0.13, 0.0.12, 0.0.11, 0.0.10, 0.0.9, 0.0.8, 0.0.7, 0.0.6, 0.0.5, 0.0.4, 0.0.3, 0.0.2, 0.0.1
npm ERR! notarget
npm ERR! notarget This is most likely not a problem with npm itself.
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn't exist.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment