Incorrect case: install_requires=["django"] in 0.2.3 #8

Open
ejucovy opened this Issue Mar 22, 2011 · 1 comment

Comments

Projects
None yet
1 participant

ejucovy commented Mar 22, 2011

django-paging 0.2.3 added "django" to its list of dependencies in its setup.py. It should be "Django", not "django".

This caused a problem for me lately, exposing an obscure bug in pip and resulting in Django 1.2.5 installed in an environment that was expecting 1.0.x (which we install from a local tarball) -- pypa/pip#239

Though you might just remove "Django" from install_requires altogether; nobody's going to install a django-* package and not have Django installed already (or have some other plan for installing it)

ejucovy commented Apr 5, 2011

This is now mitigated in the latest release by moving "django" from install_requires to tests_require, but it still ought to be changed from "django" to "Django" just to be on the safe side.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment