update requirements for pymongo #58

Merged
merged 2 commits into from Apr 9, 2015

Projects

None yet

2 participants

@karec
karec commented Apr 9, 2015

Since the 3.0 version of pymongo has broke the tests due to many backward compatibilty breaks, the fastest solution till all the corrections are in place is to force the pymongo version to 2.7 max

@dcrosta
Owner
dcrosta commented Apr 9, 2015

Thanks!

I'd slightly prefer "< 3.0" in case the MongoDB folks release patches to 2.x. Let me know if you want to update the pull request, or if I should do this on my side after I merge.

@karec
karec commented Apr 9, 2015

I've just tested with 2.8 version and all tests seems to be ok


Ran 16 tests in 0.225s

OK

I have updated the pull request and have set the PyMongo version range between 2.4 and 3.0

@dcrosta
Owner
dcrosta commented Apr 9, 2015

Great, thanks!

@dcrosta dcrosta merged commit f8caa58 into dcrosta:master Apr 9, 2015

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
@dcrosta
Owner
dcrosta commented Apr 9, 2015

This is released in version 0.3.1 -- Thanks!

@karec
karec commented Apr 9, 2015

Good news ! Thanks to you for the release !

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment