specify tmux 1.7 required #8

Closed
dgreisen opened this Issue Oct 20, 2013 · 3 comments

Projects

None yet

2 participants

@dgreisen

1.7 added the -l flag. So need to either test for its support or specify in the docs that oraide requires >=tmux 1.7.

@ddbeck
Owner
ddbeck commented Oct 22, 2013

Thank you for this information, @dgreisen. I think noting the tested tmux version(s) should be in the documentation either way and I'll try to get to that in the next day or so.

As for the actual tmux version limitation, were you prevented from using Oraide, or did you upgrade tmux? My inclination is to simply require tmux 1.7 (and provide an informative error message on versions that don't support the flag), but partial support for earlier versions might be a good idea, if upgrading is a major burden.

@dgreisen

I was running ubuntu 12.10. It did not have tmux 1.7 in its repos. I
upgraded to 13.10 and tmux was upgraded to 1.7. I think a nice error
message is more than sufficient.

On Mon, Oct 21, 2013 at 9:47 PM, Daniel D. Beck notifications@github.comwrote:

Thank you for this information, @dgreisen https://github.com/dgreisen.
I think noting the tested tmux version(s) should be in the documentation
either way and I'll try to get to that in the next day or so.

As for the actual tmux version limitation, were you prevented from using
Oraide, or did you upgrade tmux? My inclination is to simply require tmux
1.7 (and provide an informative error message on versions that don't
support the flag), but partial support for earlier versions might be a good
idea, if upgrading is a major burden.


Reply to this email directly or view it on GitHubhttps://github.com/ddbeck/oraide/issues/8#issuecomment-26771667
.

@ddbeck ddbeck pushed a commit that referenced this issue Oct 31, 2013
Daniel D. Beck add issue #8 changes to the version history 3aef725
@ddbeck ddbeck closed this in 0217b1e Oct 31, 2013
@ddbeck
Owner
ddbeck commented Oct 31, 2013

I've documented the requirement, and added a warning on import (I think this is a good balance between making the requirements clear, and flexibility in case someone's running a newer version of tmux). I credited you in the version history for this issue, @dgreisen. Thank you!

@ddbeck ddbeck pushed a commit that referenced this issue Jan 5, 2014
Daniel D. Beck attempt to get Travis CI working #8 cc1118b
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment