Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

DDNet 0.7 lite #1906

Open
def- opened this issue Sep 13, 2019 · 7 comments
Open

DDNet 0.7 lite #1906

def- opened this issue Sep 13, 2019 · 7 comments

Comments

@def-
Copy link
Member

@def- def- commented Sep 13, 2019

  • @fokkonaut is going to work on giving us a 0.7 DDNet server, he already ported DDNet server to 0.7 for his own mod so only needs to cut away a few features.
  • I will make a map converter to 0.7 today so that we will have all maps available immediately.
  • Remaining task is to take current DDNet client and apply only the network and skin related changes to have a 0.7 compatible client with the same look as current DDNet client.

We would then run a 0.7 compatible DDNet server in parallel to the current 0.6 ones and see how the acceptance is and decide on further steps.

Any volunteers?
Or thoughts about these plans?

@ChillerDragon

This comment has been minimized.

Copy link
Contributor

@ChillerDragon ChillerDragon commented Sep 14, 2019

What about using a 0.7 style client?

@Learath2

This comment has been minimized.

Copy link
Contributor

@Learath2 Learath2 commented Sep 14, 2019

@def-

This comment has been minimized.

Copy link
Member Author

@def- def- commented Sep 15, 2019

@def-

This comment has been minimized.

Copy link
Member Author

@def- def- commented Sep 16, 2019

https://github.com/ddnet/ddnet7 also exists now, thanks to @fokkonaut . What's missing is SQL. I will try to find time to add the SQL code, but if anyone wants to do it earlier, say so. Should be pretty easy to port and we'd be willing to assist.

@axblk

This comment has been minimized.

Copy link
Contributor

@axblk axblk commented Sep 16, 2019

One thing about maps: when they need to be updated anyway... what about properly extending them instead of just adding the custom layers via new flags?
Maybe the extra mapitems (#1329) can be used for this.

@def-

This comment has been minimized.

Copy link
Member Author

@def- def- commented Sep 17, 2019

https://maps.ddnet.tw/compilations/maps7.zip updated, shouldn't crash anymore.

@ChillerDragon is working on porting SQL

@ChillerDragon

This comment has been minimized.

Copy link
Contributor

@ChillerDragon ChillerDragon commented Sep 17, 2019

https://maps.ddnet.tw/compilations/maps7.zip updated, shouldn't crash anymore.

@ChillerDragon is working on porting SQL

Thanks for fixing the tool <3

About sql.. I actually tried something but I guess it would take me way too long to implement that in a nice way. So @ALL feel free to look at it.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.