Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

ruby+node.js failing #17

Closed
fotomut opened this Issue · 4 comments

5 participants

@fotomut

error:

-----> Fetching custom git buildpack... done
-----> Multipack app detected
=====> Downloading Buildpack: https://github.com/heroku/heroku-buildpack-ruby.git

 !     Push rejected, failed to compile Multipack app

I've tried every combination in my .buildpack of node.js and ruby. Even tried https://github.com/heroku/heroku-buildpack-nodejs.git#0198c71daa8 as was mentioned in a README but still it fails on the first buildpack.

https://github.com/heroku/heroku-buildpack-nodejs.git
https://github.com/heroku/heroku-buildpack-ruby.git
@fotomut

Just as a note, I only need ruby in order to install the Compass gem because my project uses the Compass SASS compiler via grunt. If there is an alternative suggestion to using the entire ruby buildpack, I'm open to that. I've tried https://github.com/stephanmelzer/heroku-buildpack-nodejs-grunt-compass alternatively but I don't need to run grunt directly during the build, which is what that pack does.

@hyzhak

Is there any changes here? I have the same issue. What should I do to run compass and sass by grunt on Heroku postintall hook? (Grunt wokrs well). But compass and sass don't

@fotcorn

This error happend to me because I didn't have a package.json in the root directory. Check if you've added a package.json/requirements.txt/Gemfile/etc. for all buildpacks in the .buildpacks files.

@rstacruz

possibly related: #35

@ddollar ddollar closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.