Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Doesn't work when database versions doesn't match #5

Closed
Bastes opened this Issue Jan 8, 2013 · 4 comments

Comments

Projects
None yet
5 participants

Bastes commented Jan 8, 2013

I'm getting these errors :

pg_dump: version du serveur : 9.1.5 ; pg_dump version : 8.4.14
pg_dump: annulation à cause de la différence des versions
pg_dump: *** interrompu du fait d'erreurs
pg_restore: [archiveur] le fichier en entrée est trop petit (0 lus, 5 attendus)

Which translates loosely to :

pg_dump: server version : 9.1.5 ; pg_dump version : 8.4.14
pg_dump: cancelling due to version divergence
pg_dump: *** stopped due to errors
pg_restore: [archiver] the entry file is too small (0 read, 5 expected)

A little more informations : my system is an Ubuntu 12.10 and I'm using rbenv to keep my rubies in line.

Same Issue:

pg_dump: server version: 9.2.4; pg_dump version: 9.1.9
pg_dump: aborting because of server version mismatch
pg_dump: *** aborted because of error

elsurudo commented Mar 6, 2014

Same thing; has anyone found a workaround?

It worked for me from 9.3.4 to 9.2.6. Thanks for the plugin!

Owner

ddollar commented Nov 7, 2014

Hello. I apologize for the delayed response. I am currently declaring issue bankruptcy. If this issue still applies to you please feel free to re-open and explain. Thanks :)

@ddollar ddollar closed this Nov 7, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment